summaryrefslogtreecommitdiffstats
path: root/tests/t-db/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:08 +0000
commit44cf9c6d2d274eac37502e835155f7e985f1b8e6 (patch)
tree9576ba968924c5b9a55ba9e14f4f26184c62c7d4 /tests/t-db/Makefile
parentAdding upstream version 1.22.6. (diff)
downloaddpkg-upstream/1.22.7.tar.xz
dpkg-upstream/1.22.7.zip
Adding upstream version 1.22.7.upstream/1.22.7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-db/Makefile')
-rw-r--r--tests/t-db/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/t-db/Makefile b/tests/t-db/Makefile
index 2e5b621..a64e28c 100644
--- a/tests/t-db/Makefile
+++ b/tests/t-db/Makefile
@@ -16,6 +16,8 @@ TEST_CASES += test-bogus-dupe-same-single
TEST_CASES += test-bogus-dupe-diff-single
TEST_CASES += test-bogus-multi
TEST_CASES += test-bogus-multi-update
+TEST_CASES += test-bogus-versioned-provides
+TEST_CASES += test-bogus-versioned-provides-update
test-case: $(TEST_CASES)
@@ -58,3 +60,11 @@ test-bogus-multi:
test-bogus-multi-update: override DPKG_ADMINDIR = db-bogus-multi-update
test-bogus-multi-update:
$(call stderr_has,$(PKG_TUPLE),error)
+
+test-bogus-versioned-provides: override DPKG_ADMINDIR = db-bogus-versioned-provides
+test-bogus-versioned-provides:
+ $(call stderr_has,$(PKG_TUPLE),warning)
+
+test-bogus-versioned-provides-update: override DPKG_ADMINDIR = db-bogus-versioned-provides-update
+test-bogus-versioned-provides-update:
+ $(call stderr_has,$(PKG_TUPLE),warning)