summaryrefslogtreecommitdiffstats
path: root/tests/t-disappear-diverted/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-disappear-diverted/Makefile
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-disappear-diverted/Makefile')
-rw-r--r--tests/t-disappear-diverted/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/tests/t-disappear-diverted/Makefile b/tests/t-disappear-diverted/Makefile
new file mode 100644
index 0000000..6df38e6
--- /dev/null
+++ b/tests/t-disappear-diverted/Makefile
@@ -0,0 +1,58 @@
+TESTS_DEB := pkg-normal pkg-divert pkg-disappear
+
+include ../Test.mk
+
+test-case:
+ # Test not disappearing diverted package.
+ $(DPKG_INSTALL) pkg-disappear.deb
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_INSTALL) pkg-divert.deb
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ # Should not disappear while it's being diverted.
+ $(call pkg_is_installed,pkg-disappear)
+ $(DPKG_PURGE) pkg-divert
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_PURGE) pkg-disappear
+ :
+ # Test disappearing package not being diverted.
+ $(DPKG_INSTALL) pkg-disappear.deb
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_INSTALL) pkg-normal.deb
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ # Should have been disappeared now.
+ $(call pkg_is_not_installed,pkg-disappear)
+ $(DPKG_PURGE) pkg-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_PURGE) pkg-disappear
+ :
+ # Test disappearing package diverted but replaced by a 3rd package.
+ $(DPKG_INSTALL) pkg-disappear.deb
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_INSTALL) pkg-divert.deb
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_INSTALL) pkg-normal.deb
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ # Should have been disappeared now, as it is diverted by a 3rd package.
+ $(call pkg_is_not_installed,pkg-disappear)
+ $(DPKG_PURGE) pkg-normal
+ test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_PURGE) pkg-divert
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal
+ ! test -e $(DPKG_INSTDIR)/test-dir/test-normal.distrib
+ $(DPKG_PURGE) pkg-disappear
+
+test-clean:
+ $(DPKG_PURGE) pkg-divert
+ $(DPKG_PURGE) pkg-disappear
+ $(DPKG_PURGE) pkg-normal
+