summaryrefslogtreecommitdiffstats
path: root/tests/t-field-priority/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-field-priority/Makefile
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-field-priority/Makefile')
-rw-r--r--tests/t-field-priority/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t-field-priority/Makefile b/tests/t-field-priority/Makefile
new file mode 100644
index 0000000..08239e7
--- /dev/null
+++ b/tests/t-field-priority/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := pkg-priority
+
+include ../Test.mk
+
+test-case:
+ # test for unknown priority values
+ $(DPKG_INSTALL) pkg-priority.deb
+ $(call pkg_is_installed,pkg-priority)
+ $(call pkg_field_is,pkg-priority,Priority,value not known)
+
+test-clean:
+ $(DPKG_PURGE) pkg-priority