summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.in44
1 files changed, 29 insertions, 15 deletions
diff --git a/Makefile.in b/Makefile.in
index b4ca8e7..2f2ad41 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -101,8 +101,8 @@ build_triplet = @build@
host_triplet = @host@
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/m4/dpkg-arch.m4 \
- $(top_srcdir)/m4/dpkg-build.m4 \
+am__aclocal_m4_deps = $(top_srcdir)/m4/build-to-host.m4 \
+ $(top_srcdir)/m4/dpkg-arch.m4 $(top_srcdir)/m4/dpkg-build.m4 \
$(top_srcdir)/m4/dpkg-compiler.m4 \
$(top_srcdir)/m4/dpkg-coverage.m4 \
$(top_srcdir)/m4/dpkg-funcs.m4 \
@@ -369,6 +369,7 @@ PACKAGE_RELEASE_DATE = @PACKAGE_RELEASE_DATE@
PACKAGE_STRING = @PACKAGE_STRING@
PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
+PACKAGE_VCS_ID = @PACKAGE_VCS_ID@
PACKAGE_VCS_TYPE = @PACKAGE_VCS_TYPE@
PACKAGE_VCS_URL = @PACKAGE_VCS_URL@
PACKAGE_VCS_WEB = @PACKAGE_VCS_WEB@
@@ -450,6 +451,8 @@ install_sh = @install_sh@
libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
+localedir_c = @localedir_c@
+localedir_c_make = @localedir_c_make@
localstatedir = @localstatedir@
logdir = @logdir@
mandir = @mandir@
@@ -517,14 +520,15 @@ dist_doc_DATA = \
# EOL
dist_docspec_DATA = \
+ doc/spec/build-driver.txt \
doc/spec/frontend-api.txt \
doc/spec/protected-field.txt \
doc/spec/rootless-builds.txt \
doc/spec/triggers.txt \
# EOL
-EXTRA_DIST = .gitlab-ci.yml .mailmap ChangeLog.old README.l10n autogen \
- build-aux/gen-changelog build-aux/gen-release \
+EXTRA_DIST = ChangeLog.old README.l10n autogen build-aux/gen-changelog \
+ build-aux/gen-release build-aux/get-vcs-id \
build-aux/get-version build-aux/lcov-inject \
build-aux/run-script build-aux/test-runner \
doc/coding-style.txt debian/README.bug-usertags \
@@ -540,14 +544,15 @@ EXTRA_DIST = .gitlab-ci.yml .mailmap ChangeLog.old README.l10n autogen \
debian/dselect.docs debian/dselect.install \
debian/dselect.lintian-overrides debian/dselect.manpages \
debian/dselect.postrm debian/libdpkg-dev.install \
- debian/libdpkg-perl.install debian/source/format \
- debian/source/lintian-overrides debian/not-installed \
- debian/rules debian/shlibs.default debian/shlibs.override \
- debian/tests/control debian/tests/test-func \
- debian/tests/test-func-root debian/tests/test-not-root \
- debian/tests/test-root po/its/polkit.its po/its/polkit.loc \
- tests $(test_scripts) $(test_data) # EOL
-@COVERAGE_ENABLED_TRUE@LCOV_OPTS = --quiet --rc geninfo_checksum=1 --rc lcov_branch_coverage=1
+ debian/libdpkg-dev.manpages debian/libdpkg-perl.install \
+ debian/source/format debian/source/lintian-overrides \
+ debian/not-installed debian/rules debian/shlibs.default \
+ debian/shlibs.override debian/tests/control \
+ debian/tests/test-func debian/tests/test-func-root \
+ debian/tests/test-not-root debian/tests/test-root \
+ po/its/polkit.its po/its/polkit.loc tests $(test_scripts) \
+ $(test_data) # EOL
+@COVERAGE_ENABLED_TRUE@LCOV_OPTS = --quiet --rc checksum=1 --rc branch_coverage=1
@COVERAGE_ENABLED_TRUE@LCOV_CAPTURE_OPTS = $(LCOV_OPTS) --no-recursion \
@COVERAGE_ENABLED_TRUE@ --directory $(top_builddir)/lib/dpkg \
@COVERAGE_ENABLED_TRUE@ --directory $(top_builddir)/src/common \
@@ -1218,8 +1223,6 @@ doc-clean:
@COVERAGE_ENABLED_TRUE@ $(LCOV) $(LCOV_OPTS) \
@COVERAGE_ENABLED_TRUE@ --add-tracefile dpkg_base.lcov \
@COVERAGE_ENABLED_TRUE@ --add-tracefile dpkg_test.lcov \
-@COVERAGE_ENABLED_TRUE@ --output-file dpkg_merge.lcov
-@COVERAGE_ENABLED_TRUE@ $(LCOV) $(LCOV_OPTS) --remove dpkg_merge.lcov '/usr/include/*' \
@COVERAGE_ENABLED_TRUE@ --output-file dpkg.lcov
@COVERAGE_ENABLED_TRUE@ : # Generate reports
@COVERAGE_ENABLED_TRUE@ $(LCOV) $(LCOV_OPTS) --list dpkg.lcov
@@ -1255,6 +1258,10 @@ tap-clean:
tap-check: $(test_data) $(test_programs) $(test_scripts)
[ -z "$(test_tmpdir)" ] || $(MKDIR_P) $(test_tmpdir)
$(TEST_ENV_VARS) \
+ TEST_PARALLEL=$(TEST_PARALLEL) \
+ TEST_VERBOSE=$(TEST_VERBOSE) \
+ abs_srcdir=$(abs_srcdir) \
+ abs_builddir=$(abs_builddir) \
abs_top_srcdir=$(abs_top_srcdir) \
abs_top_builddir=$(abs_top_builddir) \
srcdir=$(srcdir) builddir=$(builddir) \
@@ -1323,14 +1330,21 @@ dist-cpan:
# that we're not forgetting some files, and we are not storing any symlink
# in the repository (except for the origins/default one) as those degrade
# to regular files due to automake telling tar to dereference them.
+#
+# XXX: As long as we have the Makefile based functional test suite, we need
+# to remove .gitignore files from it, because we are including the entire
+# hierarchy in EXTRA_DIST.
dist-hook:
echo $(VERSION) >$(distdir)/.dist-version
+ echo $(PACKAGE_VCS_URL) >$(distdir)/.dist-vcs-url
+ echo $(PACKAGE_VCS_ID) >$(distdir)/.dist-vcs-id
+ find "$(distdir)/tests" -type f -name '.git*' | xargs rm -f
if [ -e .git ]; then \
for file in `git ls-tree -r HEAD | grep ^12 | grep -v t/origins/default`; do \
echo "$$file is a symlink packed as a file on the dist tar" >&2 ; \
exit 1 ; \
done ; \
- for file in `git ls-files | grep -vE '\.git(ignore|-blame)'`; do \
+ for file in `git ls-files | grep -vE '\.(git|mailmap)'`; do \
if [ ! -e "$(distdir)/$$file" ]; then \
echo "$$file is missing in $(distdir)" >&2 ; \
exit 1 ; \