summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b084ade..36db52e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,7 @@ AC_INIT([dpkg], m4_esyscmd([build-aux/get-version]),
[https://wiki.debian.org/Teams/Dpkg])
DPKG_DIST_IS_RELEASE
AC_SUBST([PACKAGE_COPYRIGHT_HOLDER], ['Dpkg Developers'])
+AC_SUBST([PACKAGE_VCS_ID], m4_esyscmd([build-aux/get-vcs-id]))
AC_SUBST([PACKAGE_VCS_TYPE], [git])
AC_SUBST([PACKAGE_VCS_URL], [https://git.dpkg.org/git/dpkg/dpkg.git])
AC_SUBST([PACKAGE_VCS_WEB], [https://git.dpkg.org/cgit/dpkg/dpkg.git])
@@ -127,7 +128,6 @@ AS_IF([test "x$build_start_stop_daemon" = "xyes"], [
# Checks for header files.
AC_CHECK_HEADERS([\
- stddef.h \
error.h \
err.h \
locale.h \
@@ -207,11 +207,10 @@ DPKG_CHECK_COMPAT_FUNCS([\
alphasort \
unsetenv \
])
-AC_CHECK_FUNCS([memcpy lchown],
- [], [AC_MSG_ERROR([missing required function])])
AC_CHECK_FUNCS([\
- strtoimax \
- isascii \
+ lchown \
+], [], [AC_MSG_ERROR([missing required function])])
+AC_CHECK_FUNCS([\
setsid \
getdtablesize \
getprocs64 \
@@ -274,6 +273,10 @@ AC_OUTPUT
# Print the current configuration
cat <<CONFIG
+Release:
+ Version . . . . . : $PACKAGE_VERSION
+ VCS id . . . . . : $PACKAGE_VCS_ID
+
Configuration:
Arch attributes:
cpu name . . . . . . . . . . : ${cpu_type}