summaryrefslogtreecommitdiffstats
path: root/man/nl
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--man/nl/dpkg-buildapi.pod14
-rw-r--r--man/nl/dpkg-buildflags.pod31
-rw-r--r--man/nl/dpkg-buildpackage.pod18
-rw-r--r--man/nl/dpkg-parsechangelog.pod2
-rw-r--r--man/nl/dpkg-shlibdeps.pod2
5 files changed, 55 insertions, 12 deletions
diff --git a/man/nl/dpkg-buildapi.pod b/man/nl/dpkg-buildapi.pod
index b2da9a7..c3f5a07 100644
--- a/man/nl/dpkg-buildapi.pod
+++ b/man/nl/dpkg-buildapi.pod
@@ -30,10 +30,6 @@ Dit programma werd geïntroduceerd in dpkg 1.22.0.
=over
-=item B<-c>I<control-bestand>
-
-Geeft aan wat het hoofdcontrolebestand van de broncode is waaruit informatie gehaald moet worden. Standaard is dat F<debian/control>.
-
=item B<--help>
Info tonen over het gebruik en afsluiten.
@@ -44,6 +40,16 @@ De versie tonen en afsluiten.
=back
+=head1 OPTIES
+
+=over
+
+=item B<-c>I<control-bestand>
+
+Geeft aan wat het hoofdcontrolebestand van de broncode is waaruit informatie gehaald moet worden. Standaard is dat F<debian/control>.
+
+=back
+
=head1 OMGEVING
=over
diff --git a/man/nl/dpkg-buildflags.pod b/man/nl/dpkg-buildflags.pod
index ce173d7..d2b768a 100644
--- a/man/nl/dpkg-buildflags.pod
+++ b/man/nl/dpkg-buildflags.pod
@@ -180,7 +180,7 @@ Bijvoorbeeld:
=item B<--query-features> I<gebied>
-De functies weergeven die voor een opgegeven gebied geactiveerd zijn (sinds dpkg 1.16.2). Als de functie door de compiler als een ingebouwde standaard wordt behandeld (al is het maar op sommige architecturen), dan wordt een veld B<Builtin> weergegeven (sinds dpkg 1.21.14). Momenteel worden door Debian en zijn derivaten enkel de gebieden B<future>, B<qa>, B<reproducible>, B<sanitize> en B<hardening> herkend. Zie het onderdeel B<FUNCTIEGEBIEDEN> voor meer details. Sluit af met 0 als het gebied gekend is, anders met 1.
+Print the features enabled for a given area (since dpkg 1.16.2). If the feature is handled (even if only on some architectures) as a builtin default by the compiler, then a B<Builtin> field is printed (since dpkg 1.21.14). See the L</FEATURE AREAS> section for more details about the currently recognized areas. Exits with 0 if the area is known otherwise exits with 1.
De uitvoer is in RFC822-indeling met één sectie per functie. Bijvoorbeeld:
@@ -291,13 +291,30 @@ In de toekomst kunnen nog andere vlaggen toegevoegd worden als daar behoefte aan
=head1 FUNCTIEGEBIEDEN
-Elke gebiedsfunctie kan in de gebiedswaarde van de omgevingsvariabelen B<DEB_BUILD_OPTIONS> en B<DEB_BUILD_MAINT_OPTIONS> ingeschakeld en uitgeschakeld worden met de schakelaars ‘B<+>’ en ‘B<->’. Om bijvoorbeeld de B<hardening>-functionaliteit “pie” te activeren en de functionaliteit “fortify” uit te schakelen, kunt u in B<debian/rules> het volgende doen:
+Feature areas are currently vendor specific, and the ones described below are only recognized on Debian and derivatives.
- export DEB_BUILD_MAINT_OPTIONS=hardening=+pie,-fortify
+Each area feature can be enabled and disabled in the B<DEB_BUILD_OPTIONS> and B<DEB_BUILD_MAINT_OPTIONS> environment variable's area value with the ‘B<+>’ and ‘B<->’ modifier. Following the general syntax of these variables (described in L<dpkg-buildpackage(1)>), multiple feature areas can be specified separated by spaces, where each get feature specifiers as mandatory parameters after an equal sign (‘B<=>’). The feature specifiers are comma-separated and parsed from left to right, where the settings within the same feature specifier override previous ones, even if the feature specifiers are split across multiple space-separated feature area settings for the same area.
+
+For example, to enable the B<hardening> “pie” feature and disable the “fortify” feature you can do this in B<debian/rules>:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=+pie,-fortify
De bijzondere functie B<all> (geldig in elk gebied) kan gebruikt worden om gelijktijdig alle gebiedsfunctionaliteit te activeren of uit te schakelen. Alles uitschakelen in het gebied B<hardening> en enkel “format” en “fortify” activeren kunt u dus doen met:
- export DEB_BUILD_MAINT_OPTIONS=hardening=-all,+format,+fortify
+ export DEB_BUILD_MAINT_OPTIONS = hardening=-all,+format,+fortify
+
+Multiple feature areas can be set:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=+pie abi=+lfs
+
+The override behavior applies as much to the B<all> special feature, as to specific features, which should allow for composition. Thus to enable “lfs” in the B<abi> area, and only “pie” and “fortify” in the B<hardening> area, but “format” only when CONDITION is defined, this could be done with:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=-all,+pie,+format abi=+lfs
+ …
+ DEB_BUILD_MAINT_OPTIONS += hardening=+fortify
+ ifdef CONDITION
+ DEB_BUILD_MAINT_OPTIONS += hardening=-format
+ endif
=head2 abi
@@ -313,7 +330,11 @@ Wanneer deze functie is ingeschakeld, wordt de waarde van dezelfde functie in he
=item B<time64>
-Deze instelling (sinds dpkg 1.22.0; standaard uitgezet) activeert ondersteuning voor 64-bits time_t op 32-bits architecturen waar hun ABI dit standaard niet bevat, door B<-D_TIME_BITS=64> toe te voegen aan B<CPPFLAGS>. Deze instelling schakelt automatisch de B<lfs>-functie in aangezien ze deze nodig heeft.
+This setting (since dpkg 1.22.0; enabled by default except for i386, hurd-i386 and kfreebsd-i386 since dpkg 1.22.5) enables 64-bit time_t support on 32-bit architectures where their ABI does not include it by default, by adding B<-D_TIME_BITS=64> to B<CPPFLAGS>. This setting automatically enables the B<lfs> feature from the B<abi> feature area, and the B<bug-implicit-func> feature from the B<qa> feature area as it requires them.
+
+If the setting is enabled explicitly then it gets enabled on all architectures including i386 but not hurd-i386 nor kfreebsd-i386 (where the kernel does not have time64 interfaces), ignoring the binary backwards compatibility default.
+
+It is also enabled by default by gcc on the armel, armhf, hppa, m68k, mips, mipsel, powerpc and sh4 Debian architectures, where disabling the feature will add instead B<-U_LARGEFILE_SOURCE -U_FILE_OFFSET_BITS -U_TIME_BITS> to B<CPPFLAGS>.
=back
diff --git a/man/nl/dpkg-buildpackage.pod b/man/nl/dpkg-buildpackage.pod
index 310db97..0201be9 100644
--- a/man/nl/dpkg-buildpackage.pod
+++ b/man/nl/dpkg-buildpackage.pod
@@ -514,7 +514,7 @@ Indien dit ingesteld werd, zal het gebruikt worden om de bestanden B<.changes>,
=item B<DEB_BUILD_OPTIONS>
-Indien dit ingesteld werd, zal het een door spaties gescheiden lijst met opties bevatten die het gedrag beïnvloeden van sommige dpkg-gereedschappen die betrokken zijn bij het bouwen van pakketten, en die het bouwproces van pakketten kunnen beïnvloeden als de code in F<debian/rules> deze opties erkent.
+If set, it will contain a space-separated list of options that affect the behavior of some dpkg tools involved in package building, and might affect the package build process if the code in F<debian/rules> honors them. These options can have parameters specified immediately after an equal sign (‘B<=>‘). For options that support multiple parameters, these will not be separated by spaces, as these are reserved to separate options.
Hieronder volgen de opties die bekend zijn en worden ondersteund door dpkg-gereedschappen; andere opties die worden erkend door F<debian/rules> kunnen worden gedefinieerd door distributiespecifiek beleid.
@@ -540,6 +540,22 @@ In het verpakkingsproces moet F<debian/rules> ervoor zorgen dat geen foutopspori
B<dpkg-buildpackage> zal de L<make(1)>-vlag B<--no-print-directory> toevoegen aan de omgevingsvariabele B<MAKEFLAGS>. In het verpakkingsproces moet F<debian/rules> de breedsprakigheid beperken, maar niet helemaal stil zijn.
+=item B<hardening=>I<feature-spec>
+
+=item B<reproducible=>I<feature-spec>
+
+=item B<abi=>I<feature-spec>
+
+=item B<future=>I<feature-spec>
+
+=item B<qa=>I<feature-spec>
+
+=item B<optimize=>I<feature-spec>
+
+=item B<sanitize=>I<feature-spec>
+
+These are feature areas that control build flag features. See L<dpkg-buildflags(1)> for further details.
+
=back
=item B<DEB_BUILD_PROFILES>
diff --git a/man/nl/dpkg-parsechangelog.pod b/man/nl/dpkg-parsechangelog.pod
index 577747a..8c4c2c5 100644
--- a/man/nl/dpkg-parsechangelog.pod
+++ b/man/nl/dpkg-parsechangelog.pod
@@ -34,7 +34,7 @@ Geeft het changelog-bestand op waaruit gelezen moet worden. Een ‘-’ kan gebr
=item B<-F> I<changelog-indeling>
-Geeft de indeling van het changelog-bestand aan. Standaard wordt die indeling gelezen van een bijzondere regel dicht bij het einde van het changelog-bestand en als dat mislukt, wordt er teruggevallen op de standaardindeling van B<debian>. Zie ook B<CHANGELOG FORMATS>.
+Specifies the format of the changelog. By default the format is read from a special line near the bottom of the changelog or failing that defaults to the B<debian> standard format. See also L</CHANGELOG FORMATS>.
=item B<-L> I<bibliotheekmap>
diff --git a/man/nl/dpkg-shlibdeps.pod b/man/nl/dpkg-shlibdeps.pod
index 9e9dac8..d61eaed 100644
--- a/man/nl/dpkg-shlibdeps.pod
+++ b/man/nl/dpkg-shlibdeps.pod
@@ -50,7 +50,7 @@ Door een pakket verstrekte informatie over afhankelijkheidsrelaties tot gedeelde
Tijdens het doorzoeken van de door al de programma's gebruikte symbolen, onthoudt B<dpkg-shlibdeps> van elke bibliotheek de (hoogste) minimale versie die nodig is. Op het eind van het proces is het in staat voor elke gebruikte bibliotheek uit te schrijven wat de minimale vereiste is (in de veronderstelling dat de informatie uit de I<symbols>-bestanden accuraat is).
-Bij wijze van beschermende maatregel kan een symbols-bestand een meta-informatieveld B<Build-Depends-Pakket> bevatten. Dan zal B<dpkg-shlibdeps> de door het corresponderende pakket vereiste minimale versie halen uit het veld B<Build-Depends> en deze versie gebruiken als ze hoger is dan de minimale versie die berekend werd via het doorzoeken van symbolen.
+As a safe-guard measure, a symbols file can provide a B<Build-Depends-Package> or B<Build-Depends-Packages> meta-information field and B<dpkg-shlibdeps> will extract the minimal version required by the corresponding package in the B<Build-Depends> field and use this version if it's higher than the minimal version computed by scanning symbols.
=head2 Shlibs-bestanden