summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildapi.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--scripts/mk/buildapi.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/scripts/mk/buildapi.mk b/scripts/mk/buildapi.mk
new file mode 100644
index 0000000..668e325
--- /dev/null
+++ b/scripts/mk/buildapi.mk
@@ -0,0 +1,9 @@
+# This Makefile fragment (since dpkg 1.22.0) handles the build API.
+
+# Default API level when not set.
+DPKG_BUILD_API ?= $(shell dpkg-buildapi)
+
+# We could use only built-in GNU make functions, but that seems too much
+# complexity given no integer operators, given that we currently have to
+# fetch the build API level anyway.
+dpkg_build_api_ge = $(shell test "$(DPKG_BUILD_API)" -ge "$(1)" && echo yes)