summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildflags.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mk/buildflags.mk')
-rw-r--r--scripts/mk/buildflags.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/mk/buildflags.mk b/scripts/mk/buildflags.mk
index a8eac9e..bc04488 100644
--- a/scripts/mk/buildflags.mk
+++ b/scripts/mk/buildflags.mk
@@ -57,7 +57,7 @@ dpkg_buildflags_run = $(eval $(shell \
$(foreach operation,SET STRIP APPEND PREPEND,\
DEB_$(flag)_MAINT_$(operation))),\
$(if $(value $(exported)),\
- $(exported)="$(value $(exported))"))\
+ $(exported)="$($(exported))"))\
dpkg-buildflags | sed 's/\([^=]*\)\(.*\)/$$(eval \1:\2)/'))
ifdef DPKG_EXPORT_BUILDFLAGS