summaryrefslogtreecommitdiffstats
path: root/scripts/mk
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mk')
-rw-r--r--scripts/mk/buildflags.mk2
-rw-r--r--scripts/mk/buildtools.mk4
-rw-r--r--scripts/mk/vendor.mk4
3 files changed, 7 insertions, 3 deletions
diff --git a/scripts/mk/buildflags.mk b/scripts/mk/buildflags.mk
index a8eac9e..bc04488 100644
--- a/scripts/mk/buildflags.mk
+++ b/scripts/mk/buildflags.mk
@@ -57,7 +57,7 @@ dpkg_buildflags_run = $(eval $(shell \
$(foreach operation,SET STRIP APPEND PREPEND,\
DEB_$(flag)_MAINT_$(operation))),\
$(if $(value $(exported)),\
- $(exported)="$(value $(exported))"))\
+ $(exported)="$($(exported))"))\
dpkg-buildflags | sed 's/\([^=]*\)\(.*\)/$$(eval \1:\2)/'))
ifdef DPKG_EXPORT_BUILDFLAGS
diff --git a/scripts/mk/buildtools.mk b/scripts/mk/buildtools.mk
index 1f63bee..def15c1 100644
--- a/scripts/mk/buildtools.mk
+++ b/scripts/mk/buildtools.mk
@@ -28,7 +28,9 @@
ifndef dpkg_buildtools_mk_included
dpkg_buildtools_mk_included = yes
-dpkg_datadir ?= $(dir $(lastword $(MAKEFILE_LIST)))
+ifndef dpkg_datadir
+ dpkg_datadir := $(dir $(lastword $(MAKEFILE_LIST)))
+endif
include $(dpkg_datadir)/architecture.mk
# We set the TOOL_FOR_BUILD variables to the specified value, and the TOOL
diff --git a/scripts/mk/vendor.mk b/scripts/mk/vendor.mk
index 43898d9..d257edd 100644
--- a/scripts/mk/vendor.mk
+++ b/scripts/mk/vendor.mk
@@ -36,7 +36,9 @@
ifndef dpkg_vendor_mk_included
dpkg_vendor_mk_included = yes
-dpkg_datadir ?= $(dir $(lastword $(MAKEFILE_LIST)))
+ifndef dpkg_datadir
+ dpkg_datadir := $(dir $(lastword $(MAKEFILE_LIST)))
+endif
include $(dpkg_datadir)/buildapi.mk
dpkg_lazy_eval ?= $(eval $(1) = $(2)$$($(1)))