summaryrefslogtreecommitdiffstats
path: root/scripts/t/mk/buildopts.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/t/mk/buildopts.mk')
-rw-r--r--scripts/t/mk/buildopts.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/scripts/t/mk/buildopts.mk b/scripts/t/mk/buildopts.mk
index 46d0efa..a7cf2a3 100644
--- a/scripts/t/mk/buildopts.mk
+++ b/scripts/t/mk/buildopts.mk
@@ -1,4 +1,11 @@
include $(srcdir)/mk/buildopts.mk
-test:
- test "$(DEB_BUILD_OPTION_PARALLEL)" = "$(TEST_DEB_BUILD_OPTION_PARALLEL)"
+test_vars := \
+ DEB_BUILD_OPTION_PARALLEL \
+ # EOL
+
+test: $(test_vars)
+
+$(test_vars):
+ : # Test the $@ Make variable.
+ test '$($@)' = '$(TEST_$@)'