summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rw-r--r--scripts/mk/pkg-info.mk21
-rw-r--r--scripts/po/ca.po2
-rw-r--r--scripts/po/de.po2
-rw-r--r--scripts/po/dpkg-dev.pot4
-rw-r--r--scripts/po/es.po2
-rw-r--r--scripts/po/fr.po2
-rw-r--r--scripts/po/nl.po2
-rw-r--r--scripts/po/pl.po2
-rw-r--r--scripts/po/pt.po2
-rw-r--r--scripts/po/ru.po2
-rw-r--r--scripts/po/sv.po2
-rw-r--r--scripts/t/mk/pkg-info.mk2
12 files changed, 21 insertions, 24 deletions
diff --git a/scripts/mk/pkg-info.mk b/scripts/mk/pkg-info.mk
index ddda4f7..37bf422 100644
--- a/scripts/mk/pkg-info.mk
+++ b/scripts/mk/pkg-info.mk
@@ -8,6 +8,9 @@
# DEB_VERSION_UPSTREAM: package's upstream version.
# DEB_DISTRIBUTION: distribution(s) listed in the current debian/changelog
# entry.
+# DEB_TIMESTAMP: source package release date as seconds since the epoch as
+# specified in the latest debian/changelog entry (since dpkg 1.22.9),
+# although you are probably looking for SOURCE_DATE_EPOCH instead.
#
# SOURCE_DATE_EPOCH: source release date as seconds since the epoch, as
# specified by <https://reproducible-builds.org/specs/source-date-epoch/>
@@ -26,20 +29,12 @@ dpkg_parsechangelog_run = $(eval $(shell dpkg-parsechangelog | sed -n '\
$$(eval DEB_VERSION_EPOCH_UPSTREAM:=\1\2\4)\
$$(eval DEB_VERSION_UPSTREAM_REVISION:=\2\3)\
$$(eval DEB_VERSION_UPSTREAM:=\2\4)/p;\
- s/^Timestamp: \(.*\)/$$(eval SOURCE_DATE_EPOCH?=\1)/p'))
+ s/^Timestamp: \(.*\)/$$(eval DEB_TIMESTAMP:=\1)/p'))
-ifdef SOURCE_DATE_EPOCH
- dpkg_lazy_eval ?= $(eval $(1) = $(2)$$($(1)))
- $(call dpkg_lazy_eval,DEB_DISTRIBUTION,$$(dpkg_parsechangelog_run))
- $(call dpkg_lazy_eval,DEB_SOURCE,$$(dpkg_parsechangelog_run))
- $(call dpkg_lazy_eval,DEB_VERSION,$$(dpkg_parsechangelog_run))
- $(call dpkg_lazy_eval,DEB_VERSION_EPOCH_UPSTREAM,$$(dpkg_parsechangelog_run))
- $(call dpkg_lazy_eval,DEB_VERSION_UPSTREAM,$$(dpkg_parsechangelog_run))
- $(call dpkg_lazy_eval,DEB_UPSTREAM_REVISION,$$(dpkg_parsechangelog_run))
-else
- # We need to compute the values right now.
- $(dpkg_parsechangelog_run)
-endif
+# Compute all the values in one go.
+$(dpkg_parsechangelog_run)
+
+SOURCE_DATE_EPOCH ?= $(DEB_TIMESTAMP)
export SOURCE_DATE_EPOCH
endif # dpkg_pkg_info_mk_included
diff --git a/scripts/po/ca.po b/scripts/po/ca.po
index c4cfb82..a76d7c9 100644
--- a/scripts/po/ca.po
+++ b/scripts/po/ca.po
@@ -9,7 +9,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.21.18\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2024-07-21 19:57+0200\n"
"Last-Translator: Guillem Jover <guillem@debian.org>\n"
"Language-Team: Catalan <debian-l10n-catalan@lists.debian.org>\n"
diff --git a/scripts/po/de.po b/scripts/po/de.po
index a6ca23f..959dff6 100644
--- a/scripts/po/de.po
+++ b/scripts/po/de.po
@@ -6,7 +6,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.22.6\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2024-07-03 21:25+0200\n"
"Last-Translator: Helge Kreutzmann <debian@helgefjell.de>\n"
"Language-Team: German <debian-l10n-german@lists.debian.org>\n"
diff --git a/scripts/po/dpkg-dev.pot b/scripts/po/dpkg-dev.pot
index 7c577b0..4e2741a 100644
--- a/scripts/po/dpkg-dev.pot
+++ b/scripts/po/dpkg-dev.pot
@@ -6,9 +6,9 @@
#, fuzzy
msgid ""
msgstr ""
-"Project-Id-Version: dpkg 1.22.8\n"
+"Project-Id-Version: dpkg 1.22.9\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
diff --git a/scripts/po/es.po b/scripts/po/es.po
index 6d5f8a2..7e8a128 100644
--- a/scripts/po/es.po
+++ b/scripts/po/es.po
@@ -31,7 +31,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.16.8\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2014-12-02 20:24+0100\n"
"Last-Translator: Omar Campagne <ocampagne@gmail.com>\n"
"Language-Team: Spanish <debian-l10n-spanish@lists.debian.org>\n"
diff --git a/scripts/po/fr.po b/scripts/po/fr.po
index 1faabb8..03ea7cb 100644
--- a/scripts/po/fr.po
+++ b/scripts/po/fr.po
@@ -11,7 +11,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.21.20\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2023-02-10 02:16+0100\n"
"Last-Translator: Sébastien Poher <sebastien@volted.net>\n"
"Language-Team: French <debian-l10n-french@lists.debian.org>\n"
diff --git a/scripts/po/nl.po b/scripts/po/nl.po
index bae9337..5692dce 100644
--- a/scripts/po/nl.po
+++ b/scripts/po/nl.po
@@ -8,7 +8,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.21.19\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2023-02-02 17:51+0100\n"
"Last-Translator: Frans Spiesschaert <Frans.Spiesschaert@yucom.be>\n"
"Language-Team: \n"
diff --git a/scripts/po/pl.po b/scripts/po/pl.po
index 338eda8..a083931 100644
--- a/scripts/po/pl.po
+++ b/scripts/po/pl.po
@@ -10,7 +10,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.15.4\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2015-04-07 07:05+0200\n"
"Last-Translator: Łukasz Dulny <BartekChom@poczta.onet.pl>\n"
"Language-Team: Polish <debian-l10n-polish@lists.debian.org>\n"
diff --git a/scripts/po/pt.po b/scripts/po/pt.po
index 12b389c..17e05a0 100644
--- a/scripts/po/pt.po
+++ b/scripts/po/pt.po
@@ -7,7 +7,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.22.0\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2023-03-08 22:31+0000\n"
"Last-Translator: Américo Monteiro <a_monteiro@gmx.com>\n"
"Language-Team: Portuguese <>\n"
diff --git a/scripts/po/ru.po b/scripts/po/ru.po
index 033a097..b061d7f 100644
--- a/scripts/po/ru.po
+++ b/scripts/po/ru.po
@@ -7,7 +7,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.17.23\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2015-04-07 07:02+0200\n"
"Last-Translator: Yuri Kozlov <yuray@komyakino.ru>\n"
"Language-Team: Russian <debian-l10n-russian@lists.debian.org>\n"
diff --git a/scripts/po/sv.po b/scripts/po/sv.po
index 3c48f68..725cfd8 100644
--- a/scripts/po/sv.po
+++ b/scripts/po/sv.po
@@ -7,7 +7,7 @@ msgid ""
msgstr ""
"Project-Id-Version: dpkg-dev 1.22.0\n"
"Report-Msgid-Bugs-To: debian-dpkg@lists.debian.org\n"
-"POT-Creation-Date: 2024-07-21 20:18+0200\n"
+"POT-Creation-Date: 2024-07-24 23:02+0200\n"
"PO-Revision-Date: 2024-04-28 14:34+0100\n"
"Last-Translator: Peter Krefting <peter@softwolves.pp.se>\n"
"Language-Team: Svenska <tp-sv@listor.tp-sv.se>\n"
diff --git a/scripts/t/mk/pkg-info.mk b/scripts/t/mk/pkg-info.mk
index 6eb3786..6863ebb 100644
--- a/scripts/t/mk/pkg-info.mk
+++ b/scripts/t/mk/pkg-info.mk
@@ -6,6 +6,7 @@ TEST_DEB_VERSION_EPOCH_UPSTREAM = 1:2:3.4-5
TEST_DEB_VERSION_UPSTREAM_REVISION = 2:3.4-5-6
TEST_DEB_VERSION_UPSTREAM = 2:3.4-5
TEST_DEB_DISTRIBUTION = suite
+TEST_DEB_TIMESTAMP = 1438697630
test_vars := \
DEB_SOURCE \
@@ -14,6 +15,7 @@ test_vars := \
DEB_VERSION_UPSTREAM_REVISION \
DEB_VERSION_UPSTREAM \
DEB_DISTRIBUTION \
+ DEB_TIMESTAMP \
SOURCE_DATE_EPOCH \
# EOL