summaryrefslogtreecommitdiffstats
path: root/tests/Test.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/Test.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Test.mk b/tests/Test.mk
index 3c020af..a830d5d 100644
--- a/tests/Test.mk
+++ b/tests/Test.mk
@@ -27,6 +27,9 @@ DPKG_ENV = \
# eatmydata confuses ASAN link order check.
export ASAN_OPTIONS = verify_asan_link_order=0
+# Do not fail due to leaks, as the code is still using lots of
+# static variables and error variables.
+export LSAN_OPTIONS = exitcode=0
ifdef DPKG_BUILDTREE
export DPKG_DATADIR := $(DPKG_BUILDTREE)/src