summaryrefslogtreecommitdiffstats
path: root/tests/t-breaks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-breaks/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t-breaks/Makefile b/tests/t-breaks/Makefile
new file mode 100644
index 0000000..9ffd02c
--- /dev/null
+++ b/tests/t-breaks/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := lib-a-0 lib-a-1 lib-b-0 lib-b-1 pkg-c
+
+include ../Test.mk
+
+DPKG_OPTIONS += --auto-deconfigure
+
+test-case:
+ $(DPKG_INSTALL) lib-a-0.deb lib-b-0.deb
+ $(DPKG_INSTALL) pkg-c.deb lib-a-1.deb lib-b-1.deb
+
+test-clean:
+ $(DPKG_PURGE) lib-a lib-b pkg-c