summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-forcemiss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-conffile-forcemiss/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/t-conffile-forcemiss/Makefile b/tests/t-conffile-forcemiss/Makefile
new file mode 100644
index 0000000..ab36890
--- /dev/null
+++ b/tests/t-conffile-forcemiss/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-conff-forcemiss-0 pkg-conff-forcemiss-1
+
+include ../Test.mk
+
+test-case:
+ # Test if we get the new conffile after a missing one.
+ $(DPKG_INSTALL) pkg-conff-forcemiss-0.deb
+ $(BEROOT) rm "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_INSTALL) pkg-conff-forcemiss-1.deb
+ ! test -f "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_INSTALL) --force-confmiss pkg-conff-forcemiss-1.deb
+ cmp ref-conffile "$(DPKG_INSTDIR)/test-conffile"
+ $(DPKG_PURGE) pkg-conff-forcemiss
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-forcemiss