summaryrefslogtreecommitdiffstats
path: root/tests/t-disappear-diverted-other/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-disappear-diverted-other/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/t-disappear-diverted-other/Makefile b/tests/t-disappear-diverted-other/Makefile
new file mode 100644
index 0000000..d483b9a
--- /dev/null
+++ b/tests/t-disappear-diverted-other/Makefile
@@ -0,0 +1,28 @@
+TESTS_DEB := pkg-divert pkg-diverted pkg-replaces
+
+include ../Test.mk
+
+test-case:
+ # Test disappearing diverted package with a not contended pathname.
+ $(DPKG_INSTALL) pkg-divert.deb
+ $(DPKG_INSTALL) pkg-diverted.deb
+ $(DPKG_INSTALL) pkg-replaces.deb
+ # Should disappear because there is no contended pathname.
+ $(call pkg_is_not_installed,pkg-divert)
+ $(DPKG_PURGE) pkg-divert
+ $(DPKG_PURGE) pkg-diverted
+ $(DPKG_PURGE) pkg-replaces
+ :
+ # Test disappearing diverted package with a not contended pathname.
+ $(DPKG_INSTALL) pkg-divert.deb
+ $(DPKG_INSTALL) pkg-replaces.deb
+ # Should disappear because there is no contended pathname.
+ $(call pkg_is_not_installed,pkg-divert)
+ $(DPKG_PURGE) pkg-divert
+ $(DPKG_PURGE) pkg-replaces
+
+test-clean:
+ $(DPKG_PURGE) pkg-divert
+ $(DPKG_PURGE) pkg-diverted
+ $(DPKG_PURGE) pkg-replaces
+