summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-symlink/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-unpack-symlink/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/t-unpack-symlink/Makefile b/tests/t-unpack-symlink/Makefile
new file mode 100644
index 0000000..518ca4e
--- /dev/null
+++ b/tests/t-unpack-symlink/Makefile
@@ -0,0 +1,20 @@
+TESTS_DEB := pkg-symlink
+
+include ../Test.mk
+
+build-hook:
+ ln -fs test-file pkg-symlink/test-symlink
+
+clean-hook:
+ $(RM) pkg-symlink/test-symlink
+
+test-case:
+ # test unpacking symlinks
+ $(DPKG_INSTALL) pkg-symlink.deb
+ $(call pkg_is_installed,pkg-symlink)
+ test -f "$(DPKG_INSTDIR)/test-file"
+ test -L "$(DPKG_INSTDIR)/test-symlink"
+ test "`readlink '$(DPKG_INSTDIR)/test-symlink'`" = "test-file"
+
+test-clean:
+ $(DPKG_PURGE) pkg-symlink