summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am60
1 files changed, 34 insertions, 26 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 71873a5..2ce3bce 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -11,24 +11,35 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/lib \
# EOL
-CLEANFILES = \
- org.dpkg.pkexec.update-alternatives.policy \
+sbin_PROGRAMS =
+bin_PROGRAMS =
+dist_bashcompletions_DATA =
+polkitactions_DATA =
+EXTRA_DIST =
+CLEANFILES =
+
+if BUILD_UPDATE_ALTERNATIVES
+bin_PROGRAMS += update-alternatives
+
+update_alternatives_CPPFLAGS = \
+ -DALT_TMP_EXT=\".dpkg-tmp\" \
+ -DADMINDIR_ENVVAR=\"DPKG_ADMINDIR\" \
+ -DINSTDIR_ENVVAR=\"DPKG_ROOT\" \
+ $(AM_CPPFLAGS) \
# EOL
-EXTRA_DIST = \
- README.alternatives \
- update-alternatives.polkit.in \
- $(test_scripts) \
+update_alternatives_SOURCES = \
+ update-alternatives.c \
# EOL
-pkexecdir = $(datadir)/polkit-1/actions
-pkexec_DATA =
+update_alternatives_LDADD = \
+ ../lib/compat/libcompat.la \
+ $(LIBINTL) \
+ # EOL
-bin_PROGRAMS =
+dist_bashcompletions_DATA +=
-if BUILD_UPDATE_ALTERNATIVES
-pkexec_DATA += org.dpkg.pkexec.update-alternatives.policy
-bin_PROGRAMS += update-alternatives
+polkitactions_DATA += org.dpkg.pkexec.update-alternatives.policy
endif
do_polkit_subst = $(SED) \
@@ -41,24 +52,15 @@ org.dpkg.pkexec.update-alternatives.policy: update-alternatives.polkit.in Makefi
$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o - \
| $(do_polkit_subst) >$@
-update_alternatives_SOURCES = \
- update-alternatives.c \
- # EOL
-
-update_alternatives_CPPFLAGS = \
- -DALT_TMP_EXT=\".dpkg-tmp\" \
- -DADMINDIR_ENVVAR=\"DPKG_ADMINDIR\" \
- -DINSTDIR_ENVVAR=\"DPKG_ROOT\" \
- $(AM_CPPFLAGS) \
+EXTRA_DIST += \
+ README.alternatives \
+ update-alternatives.polkit.in \
# EOL
-update_alternatives_LDADD = \
- ../lib/compat/libcompat.la \
- $(LIBINTL) \
+CLEANFILES += \
+ org.dpkg.pkexec.update-alternatives.policy \
# EOL
-sbin_PROGRAMS =
-
if BUILD_START_STOP_DAEMON
sbin_PROGRAMS += start-stop-daemon
@@ -72,6 +74,8 @@ start_stop_daemon_LDADD = \
$(PS_LIBS) \
$(KVM_LIBS) \
# EOL
+
+dist_bashcompletions_DATA +=
endif
install-data-local:
@@ -96,6 +100,10 @@ test_scripts = \
t/update_alternatives.t \
# EOL
+EXTRA_DIST += \
+ $(test_scripts) \
+ # EOL
+
include $(top_srcdir)/build-aux/tap.am
check-local: tap-check