summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:59:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:59:56 +0000
commit3907848646f9ce4a4706227a291eafb59271dc6c (patch)
treeffe01e4ab4002e07603db61c81d197f84fb2744b
parentAdding debian version 060+5-7. (diff)
downloaddracut-3907848646f9ce4a4706227a291eafb59271dc6c.tar.xz
dracut-3907848646f9ce4a4706227a291eafb59271dc6c.zip
Adding debian version 060+5-8.debian/060+5-8
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control4
-rw-r--r--debian/patches/04b362d713235459cff1f370efb4cd5e36e4a358.patch69
-rw-r--r--debian/patches/series1
4 files changed, 79 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 43fffa1..ac35fda 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dracut (060+5-8) unstable; urgency=low
+
+ * control: adjust breaks, replaces, Closes: #1071208, #1071244
+ * add patch taken from dracut-ng, Closes: #1071182
+
+ -- Thomas Lange <lange@debian.org> Sun, 19 May 2024 16:45:33 +0200
+
dracut (060+5-7) unstable; urgency=low
* control: update package depends name
diff --git a/debian/control b/debian/control
index 1ac803f..2e235ad 100644
--- a/debian/control
+++ b/debian/control
@@ -41,8 +41,8 @@ Description: dracut is an event driven initramfs infrastructure (core tools)
Package: dracut-install
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
-Breaks: dracut-core (<< 059-5~)
-Replaces: dracut-core (<< 059-5~)
+Breaks: dracut-core (<< 060+5-7~)
+Replaces: dracut-core (<< 060+5-7~)
Description: dracut is an event driven initramfs infrastructure (dracut-install)
This package just contains the dracut-install command to be used by
initramfs generating tools.
diff --git a/debian/patches/04b362d713235459cff1f370efb4cd5e36e4a358.patch b/debian/patches/04b362d713235459cff1f370efb4cd5e36e4a358.patch
new file mode 100644
index 0000000..07cea4f
--- /dev/null
+++ b/debian/patches/04b362d713235459cff1f370efb4cd5e36e4a358.patch
@@ -0,0 +1,69 @@
+From 04b362d713235459cff1f370efb4cd5e36e4a358 Mon Sep 17 00:00:00 2001
+From: Antonio Alvarez Feijoo <antonio.feijoo@suse.com>
+Date: Thu, 4 Apr 2024 13:49:26 +0200
+Subject: [PATCH] fix(systemd): explicitly install some libs that will not be
+ statically included
+
+Some required libraries that used to be statically included are in the process
+to be opened via `dlopen()`.
+
+References:
+- https://github.com/systemd/systemd/pull/31131
+- https://github.com/systemd/systemd/pull/31550
+- https://github.com/systemd/systemd/pull/32019
+
+Closes #2642
+---
+ modules.d/00systemd/module-setup.sh | 2 ++
+ modules.d/01systemd-coredump/module-setup.sh | 7 +++++++
+ modules.d/01systemd-journald/module-setup.sh | 5 +++--
+ 3 files changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/modules.d/00systemd/module-setup.sh b/modules.d/00systemd/module-setup.sh
+index 66e08ea69..723417464 100755
+--- a/modules.d/00systemd/module-setup.sh
++++ b/modules.d/00systemd/module-setup.sh
+@@ -260,6 +260,8 @@ EOF
+ # Install library file(s)
+ _arch=${DRACUT_ARCH:-$(uname -m)}
+ inst_libdir_file \
++ {"tls/$_arch/",tls/,"$_arch/",}"libgcrypt.so*" \
++ {"tls/$_arch/",tls/,"$_arch/",}"libkmod.so*" \
+ {"tls/$_arch/",tls/,"$_arch/",}"libnss_*"
+
+ }
+diff --git a/modules.d/01systemd-coredump/module-setup.sh b/modules.d/01systemd-coredump/module-setup.sh
+index 69ec96686..47666b6ca 100755
+--- a/modules.d/01systemd-coredump/module-setup.sh
++++ b/modules.d/01systemd-coredump/module-setup.sh
+@@ -40,6 +40,13 @@ install() {
+ "$sysusers"/systemd-coredump.conf \
+ coredumpctl
+
++ # Install library file(s)
++ _arch=${DRACUT_ARCH:-$(uname -m)}
++ inst_libdir_file \
++ {"tls/$_arch/",tls/,"$_arch/",}"liblz4.so.*" \
++ {"tls/$_arch/",tls/,"$_arch/",}"liblzma.so.*" \
++ {"tls/$_arch/",tls/,"$_arch/",}"libzstd.so.*"
++
+ # Install the hosts local user configurations if enabled.
+ if [[ $hostonly ]]; then
+ inst_multiple -H -o \
+diff --git a/modules.d/01systemd-journald/module-setup.sh b/modules.d/01systemd-journald/module-setup.sh
+index 3cf2a1a11..276e75282 100755
+--- a/modules.d/01systemd-journald/module-setup.sh
++++ b/modules.d/01systemd-journald/module-setup.sh
+@@ -53,9 +53,10 @@ install() {
+ # Install library file(s)
+ _arch=${DRACUT_ARCH:-$(uname -m)}
+ inst_libdir_file \
++ {"tls/$_arch/",tls/,"$_arch/",}"libgcrypt.so*" \
+ {"tls/$_arch/",tls/,"$_arch/",}"liblz4.so.*" \
+- {"tls/$_arch/",tls/,"$_arch/",}"libzstd.so.*" \
+- {"tls/$_arch/",tls/,"$_arch/",}"liblzma.so.*"
++ {"tls/$_arch/",tls/,"$_arch/",}"liblzma.so.*" \
++ {"tls/$_arch/",tls/,"$_arch/",}"libzstd.so.*"
+
+ # Install the hosts local user configurations if enabled.
+ if [[ $hostonly ]]; then
diff --git a/debian/patches/series b/debian/patches/series
index 74e9921..ae21e64 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
+04b362d713235459cff1f370efb4cd5e36e4a358.patch
rpc-user
udevsettle
nm-path