summaryrefslogtreecommitdiffstats
path: root/test/TEST-04-FULL-SYSTEMD
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:54:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:54:25 +0000
commit9cb1c4df7b9ce1a9ad1312621b0f2b16a94fba3a (patch)
tree2efb72864cc69e174c9c5ee33efb88a5f1553b48 /test/TEST-04-FULL-SYSTEMD
parentInitial commit. (diff)
downloaddracut-9cb1c4df7b9ce1a9ad1312621b0f2b16a94fba3a.tar.xz
dracut-9cb1c4df7b9ce1a9ad1312621b0f2b16a94fba3a.zip
Adding upstream version 060+5.upstream/060+5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/TEST-04-FULL-SYSTEMD')
-rw-r--r--test/TEST-04-FULL-SYSTEMD/Makefile1
-rwxr-xr-xtest/TEST-04-FULL-SYSTEMD/create-root.sh33
-rw-r--r--test/TEST-04-FULL-SYSTEMD/fstab2
-rwxr-xr-xtest/TEST-04-FULL-SYSTEMD/test-init.sh41
-rwxr-xr-xtest/TEST-04-FULL-SYSTEMD/test.sh163
5 files changed, 240 insertions, 0 deletions
diff --git a/test/TEST-04-FULL-SYSTEMD/Makefile b/test/TEST-04-FULL-SYSTEMD/Makefile
new file mode 100644
index 0000000..2dcab81
--- /dev/null
+++ b/test/TEST-04-FULL-SYSTEMD/Makefile
@@ -0,0 +1 @@
+-include ../Makefile.testdir
diff --git a/test/TEST-04-FULL-SYSTEMD/create-root.sh b/test/TEST-04-FULL-SYSTEMD/create-root.sh
new file mode 100755
index 0000000..411fa99
--- /dev/null
+++ b/test/TEST-04-FULL-SYSTEMD/create-root.sh
@@ -0,0 +1,33 @@
+#!/bin/sh
+
+trap 'poweroff -f' EXIT
+
+# don't let udev and this script step on eachother's toes
+for x in 64-lvm.rules 70-mdadm.rules 99-mount-rules; do
+ : > "/etc/udev/rules.d/$x"
+done
+rm -f -- /etc/lvm/lvm.conf
+udevadm control --reload
+set -e
+
+udevadm settle
+modprobe btrfs || :
+mkfs.btrfs -L dracut /dev/disk/by-id/ata-disk_root
+mkfs.btrfs -L dracutusr /dev/disk/by-id/ata-disk_usr
+btrfs device scan /dev/disk/by-id/ata-disk_root
+btrfs device scan /dev/disk/by-id/ata-disk_usr
+mkdir -p /root
+mount -t btrfs /dev/disk/by-id/ata-disk_root /root
+[ -d /root/usr ] || mkdir -p /root/usr
+mount -t btrfs /dev/disk/by-id/ata-disk_usr /root/usr
+btrfs subvolume create /root/usr/usr
+umount /root/usr
+mount -t btrfs -o subvol=usr /dev/disk/by-id/ata-disk_usr /root/usr
+cp -a -t /root /source/*
+mkdir -p /root/run
+btrfs filesystem sync /root/usr
+btrfs filesystem sync /root
+umount /root/usr
+umount /root
+echo "dracut-root-block-created" | dd oflag=direct,dsync of=/dev/disk/by-id/ata-disk_marker
+poweroff -f
diff --git a/test/TEST-04-FULL-SYSTEMD/fstab b/test/TEST-04-FULL-SYSTEMD/fstab
new file mode 100644
index 0000000..feac57a
--- /dev/null
+++ b/test/TEST-04-FULL-SYSTEMD/fstab
@@ -0,0 +1,2 @@
+/dev/disk/by-id/ata-disk_root / btrfs defaults 0 0
+/dev/disk/by-id/ata-disk_usr /usr btrfs subvol=usr,ro 0 0
diff --git a/test/TEST-04-FULL-SYSTEMD/test-init.sh b/test/TEST-04-FULL-SYSTEMD/test-init.sh
new file mode 100755
index 0000000..b7261b5
--- /dev/null
+++ b/test/TEST-04-FULL-SYSTEMD/test-init.sh
@@ -0,0 +1,41 @@
+#!/bin/sh
+: > /dev/watchdog
+
+. /lib/dracut-lib.sh
+
+export PATH=/usr/sbin:/usr/bin:/sbin:/bin
+command -v plymouth > /dev/null 2>&1 && plymouth --quit
+exec > /dev/console 2>&1
+
+systemctl --failed --no-legend --no-pager > /failed
+
+if ! ismounted /usr; then
+ echo "**************************FAILED**************************"
+ echo "/usr not mounted!!"
+ cat /proc/mounts
+ echo "**************************FAILED**************************"
+else
+ if [ -s /failed ]; then
+ echo "**************************FAILED**************************"
+ cat /failed
+ echo "**************************FAILED**************************"
+
+ else
+ echo "dracut-root-block-success" | dd oflag=direct,dsync of=/dev/disk/by-id/ata-disk_marker
+ echo "All OK"
+ fi
+fi
+
+export TERM=linux
+export PS1='initramfs-test:\w\$ '
+[ -f /etc/mtab ] || ln -sfn /proc/mounts /etc/mtab
+[ -f /etc/fstab ] || ln -sfn /proc/mounts /etc/fstab
+stty sane
+echo "made it to the rootfs!"
+if getargbool 0 rd.shell; then
+ strstr "$(setsid --help)" "control" && CTTY="-c"
+ setsid $CTTY sh -i
+fi
+echo "Powering down."
+systemctl --no-block poweroff
+exit 0
diff --git a/test/TEST-04-FULL-SYSTEMD/test.sh b/test/TEST-04-FULL-SYSTEMD/test.sh
new file mode 100755
index 0000000..160104f
--- /dev/null
+++ b/test/TEST-04-FULL-SYSTEMD/test.sh
@@ -0,0 +1,163 @@
+#!/bin/bash
+
+# shellcheck disable=SC2034
+TEST_DESCRIPTION="Full systemd serialization/deserialization test with /usr mount"
+
+test_check() {
+ command -v systemctl &> /dev/null
+}
+
+# Uncomment this to debug failures
+#DEBUGFAIL="rd.shell rd.break"
+#DEBUGOUT="quiet systemd.log_level=debug systemd.log_target=console loglevel=77 rd.info rd.debug"
+DEBUGOUT="loglevel=0 "
+client_run() {
+ local test_name="$1"
+ shift
+ local client_opts="$*"
+
+ echo "CLIENT TEST START: $test_name"
+
+ declare -a disk_args=()
+ declare -i disk_index=0
+ qemu_add_drive_args disk_index disk_args "$TESTDIR"/marker.img marker
+ qemu_add_drive_args disk_index disk_args "$TESTDIR"/root.btrfs root
+ qemu_add_drive_args disk_index disk_args "$TESTDIR"/usr.btrfs usr
+
+ test_marker_reset
+ "$testdir"/run-qemu \
+ "${disk_args[@]}" \
+ -append "systemd.unit=testsuite.target systemd.mask=systemd-firstboot panic=1 oops=panic softlockup_panic=1 systemd.crash_reboot root=LABEL=dracut $client_opts rd.retry=3 console=ttyS0,115200n81 selinux=0 $DEBUGOUT rd.shell=0 $DEBUGFAIL" \
+ -initrd "$TESTDIR"/initramfs.testing || return 1
+
+ if ! test_marker_check; then
+ echo "CLIENT TEST END: $test_name [FAILED]"
+ return 1
+ fi
+ echo "CLIENT TEST END: $test_name [OK]"
+
+}
+
+test_run() {
+ client_run "no option specified" || return 1
+ client_run "readonly root" "ro" || return 1
+ client_run "writeable root" "rw" || return 1
+ return 0
+}
+
+test_setup() {
+ # shellcheck disable=SC2064
+ trap "$(shopt -p globstar)" RETURN
+ shopt -q -s globstar
+
+ # Create what will eventually be our root filesystem onto an overlay
+ "$DRACUT" -l --keep --tmpdir "$TESTDIR" \
+ -m "test-root dbus" \
+ -I "ldconfig" \
+ -i ./test-init.sh /sbin/test-init \
+ -i ./fstab /etc/fstab \
+ -i "${PKGLIBDIR}/modules.d/99base/dracut-lib.sh" "/lib/dracut-lib.sh" \
+ -i "${PKGLIBDIR}/modules.d/99base/dracut-dev-lib.sh" "/lib/dracut-dev-lib.sh" \
+ --no-hostonly --no-hostonly-cmdline --nomdadmconf --nohardlink \
+ -f "$TESTDIR"/initramfs.root "$KVERSION" || return 1
+
+ mkdir -p "$TESTDIR"/overlay/source && cp -a "$TESTDIR"/dracut.*/initramfs/* "$TESTDIR"/overlay/source && rm -rf "$TESTDIR"/dracut.* && export initdir=$TESTDIR/overlay/source
+
+ if type -P rpm &> /dev/null; then
+ rpm -ql systemd | xargs -r "$PKGLIBDIR"/dracut-install ${initdir:+-D "$initdir"} -o -a -l
+ elif type -P dpkg &> /dev/null; then
+ dpkg -L systemd | xargs -r "$PKGLIBDIR"/dracut-install ${initdir:+-D "$initdir"} -o -a -l
+ elif type -P pacman &> /dev/null; then
+ pacman -Q -l systemd | while read -r _ a; do printf -- "%s\0" "$a"; done | xargs -0 -r "$PKGLIBDIR"/dracut-install ${initdir:+-D "$initdir"} -o -a -l
+ else
+ echo "Can't install systemd base"
+ return 1
+ fi
+
+ # softlink mtab
+ ln -fs /proc/self/mounts "$initdir"/etc/mtab
+
+ # install any Execs from the service files
+ grep -Eho '^Exec[^ ]*=[^ ]+' "$initdir"{,/usr}/lib/systemd/system/*.service \
+ | while read -r i || [ -n "$i" ]; do
+ i=${i##Exec*=}
+ i=${i##-}
+ "$PKGLIBDIR"/dracut-install ${initdir:+-D "$initdir"} -o -a -l "$i"
+ done
+
+ # setup the testsuite target
+ mkdir -p "$initdir"/etc/systemd/system
+ cat > "$initdir"/etc/systemd/system/testsuite.target << EOF
+[Unit]
+Description=Testsuite target
+Requires=basic.target
+After=basic.target
+Conflicts=rescue.target
+AllowIsolate=yes
+EOF
+
+ # setup the testsuite service
+ cat > "$initdir"/etc/systemd/system/testsuite.service << EOF
+[Unit]
+Description=Testsuite service
+After=basic.target
+
+[Service]
+ExecStart=/sbin/test-init
+Type=oneshot
+StandardInput=tty
+StandardOutput=tty
+EOF
+
+ mkdir -p "$initdir"/etc/systemd/system/testsuite.target.wants
+ ln -fs ../testsuite.service "$initdir"/etc/systemd/system/testsuite.target.wants/testsuite.service
+
+ # second, install the files needed to make the root filesystem
+ # create an initramfs that will create the target root filesystem.
+ # We do it this way so that we do not risk trashing the host mdraid
+ # devices, volume groups, encrypted partitions, etc.
+ "$DRACUT" -l -i "$TESTDIR"/overlay / \
+ -m "test-makeroot bash btrfs" \
+ -I "mkfs.btrfs" \
+ -i ./create-root.sh /lib/dracut/hooks/initqueue/01-create-root.sh \
+ --nomdadmconf \
+ --nohardlink \
+ --no-hostonly-cmdline -N \
+ -f "$TESTDIR"/initramfs.makeroot "$KVERSION" || return 1
+ rm -rf -- "$TESTDIR"/overlay/*
+
+ # Create the blank file to use as a root filesystem
+ declare -a disk_args=()
+ # shellcheck disable=SC2034
+ declare -i disk_index=0
+ qemu_add_drive_args disk_index disk_args "$TESTDIR"/marker.img marker 1
+ qemu_add_drive_args disk_index disk_args "$TESTDIR"/root.btrfs root 160
+ qemu_add_drive_args disk_index disk_args "$TESTDIR"/usr.btrfs usr 160
+
+ # Invoke KVM and/or QEMU to actually create the target filesystem.
+ "$testdir"/run-qemu \
+ "${disk_args[@]}" \
+ -append "root=/dev/fakeroot rw rootfstype=btrfs quiet console=ttyS0,115200n81 selinux=0" \
+ -initrd "$TESTDIR"/initramfs.makeroot || return 1
+
+ if ! test_marker_check dracut-root-block-created; then
+ echo "Could not create root filesystem"
+ return 1
+ fi
+
+ [ -e /etc/machine-id ] && EXTRA_MACHINE="/etc/machine-id"
+ [ -e /etc/machine-info ] && EXTRA_MACHINE+=" /etc/machine-info"
+
+ "$DRACUT" -l -i "$TESTDIR"/overlay / \
+ -a "test systemd i18n qemu" \
+ ${EXTRA_MACHINE:+-I "$EXTRA_MACHINE"} \
+ -o "network plymouth lvm mdraid resume crypt caps dm terminfo usrmount kernel-network-modules rngd" \
+ -d "piix ide-gd_mod ata_piix btrfs sd_mod i6300esb ib700wdt" \
+ --no-hostonly-cmdline -N \
+ -f "$TESTDIR"/initramfs.testing "$KVERSION" || return 1
+
+ rm -rf -- "$TESTDIR"/overlay
+}
+
+# shellcheck disable=SC1090
+. "$testdir"/test-functions