summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index bce1c66..b6f1f77 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,11 +9,13 @@ DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
export DRACUT_MAIN_VERSION=$(DEB_VERSION_UPSTREAM_REVISION)
export DRACUT_FULL_VERSION=$(DEB_VERSION)
+deb_systemdsystemunitdir = $(shell pkg-config --variable=systemdsystemunitdir systemd | sed s,^/,,)
+
%:
dh $@
override_dh_auto_configure:
- dh_auto_configure -- --systemdsystemunitdir=/lib/systemd/system --libdir=/usr/lib
+ dh_auto_configure -- --systemdsystemunitdir=/$(deb_systemdsystemunitdir) --libdir=/usr/lib
$(SHELL) debian/fix-revdate
mv dracut-version.sh dracut-version.sh.orig
echo '#!/bin/sh' > dracut-version.sh
@@ -40,6 +42,10 @@ endif
override_dh_auto_test:
+override_dh_install:
+ dh_install
+ dh_install -pdracut-core $(deb_systemdsystemunitdir)
+
override_dh_clean:
if test -e dracut-version.sh.orig ; then \
mv -f dracut-version.sh.orig dracut-version.sh ;\