summaryrefslogtreecommitdiffstats
path: root/test/Makefile.testdir
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.testdir')
-rw-r--r--test/Makefile.testdir10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile.testdir b/test/Makefile.testdir
new file mode 100644
index 0000000..e3b31b1
--- /dev/null
+++ b/test/Makefile.testdir
@@ -0,0 +1,10 @@
+.PHONY: all setup clean run
+
+all:
+ @V=$(V) testdir="$(realpath ../)" ./test.sh --all
+setup:
+ @testdir="$(realpath ../)" ./test.sh --setup
+clean:
+ @testdir="$(realpath ../)" ./test.sh --clean
+run:
+ @testdir="$(realpath ../)" ./test.sh --run