summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 09:29:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 09:29:41 +0000
commit9145cb9d9854ebbe77702d278b82e042b82ca28b (patch)
tree37261299c456d6acc634add0baeb6b00a1439346 /debian/rules
parentAdding debian version 1.47.0-2. (diff)
downloade2fsprogs-9145cb9d9854ebbe77702d278b82e042b82ca28b.tar.xz
e2fsprogs-9145cb9d9854ebbe77702d278b82e042b82ca28b.zip
Adding debian version 1.47.0-2.4.debian/1.47.0-2.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index b85976f..73337d3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,11 @@ ifeq ($(DEB_HOST_ARCH_OS), hurd)
SKIP_FUSE2FS=yes
endif
+ifeq ($(DEB_HOST_ARCH_OS), linux)
+export deb_systemdsystemunitdir = $(shell pkg-config --variable=systemdsystemunitdir systemd | sed s,^/,,)
+export deb_udevudevdir = $(shell pkg-config pkg-config --variable=udevdir udev | sed s,^/,,)
+endif
+
ifneq ($(filter pkg.e2fsprogs.no-fuse2fs,$(DEB_BUILD_PROFILES)),)
SKIP_FUSE2FS=yes
endif
@@ -30,7 +35,7 @@ INSTALL ?= install
INSTALL_PROGRAM ?= $(INSTALL) -p -m 0755
ifneq (,$(findstring update-symbols,$(DEB_BUILD_OPTIONS)))
-SYMBOL_LIBS := libext2fs libcomerr2 libss2
+SYMBOL_LIBS := libext2fst64 libcomerr2 libss2
endif
CFLAGS_SHLIB = $(CFLAGS)