summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:00:07 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 08:00:07 +0000
commit71b1940231738aac70ede9ecb211614eae8873aa (patch)
treed42a8e658862d9e2c3d2ec144394170bc321f5a0 /Makefile
parentInitial commit. (diff)
downloadeas4tbsync-71b1940231738aac70ede9ecb211614eae8873aa.tar.xz
eas4tbsync-71b1940231738aac70ede9ecb211614eae8873aa.zip
Adding upstream version 4.7.upstream/4.7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..644acbb
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,25 @@
+# This file is part of EAS-4-TbSync.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+PACKAGE_NAME=EAS-4-TbSync
+
+ARCHIVE_NAME=$(PACKAGE_NAME).xpi
+
+PACKAGE_FILES= \
+ content \
+ _locales \
+ manifest.json \
+ CONTRIBUTORS.md \
+ LICENSE README.md \
+ background.js
+
+all: clean $(PACKAGE_FILES)
+ zip -r $(ARCHIVE_NAME) $(PACKAGE_FILES)
+
+clean:
+ rm -f $(ARCHIVE_NAME)
+
+.PHONY: clean