summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/changelog20
-rwxr-xr-xdebian/rules7
-rw-r--r--debian/tests/control7
-rw-r--r--debian/tests/create-files35
-rwxr-xr-xdebian/tests/fsck10
-rw-r--r--debian/watch2
6 files changed, 80 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8c8ce19..3587d62 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,23 @@
+exfatprogs (1.2.5-1) unstable; urgency=medium
+
+ * New upstream release.
+ + Fixes for exfat.fsck on big-endian architectures.
+ + Upstream release tarball now contains also the tests folder.
+ * Remove debian/README.source and Add-tests-folder-from-upstream patch.
+
+ -- Sven Hoexter <hoexter@debian.org> Tue, 13 Aug 2024 11:53:29 +0200
+
+exfatprogs (1.2.4-2) experimental; urgency=medium
+
+ * Adjust debian/watch to download the release tarball,
+ instead of the auto-generated GitHub source tarball.
+ Patch by Alessandro Astone. (Closes: #1076722)
+ * Include and run upstream tests. Tests are imported
+ as one big patch out of upstreams git (see README.source
+ for the details). Patches by Alessandro Astone. (Closes: #1076705)
+
+ -- Sven Hoexter <hoexter@debian.org> Fri, 26 Jul 2024 15:18:42 +0200
+
exfatprogs (1.2.4-1~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/rules b/debian/rules
index d3e0345..e3df3d6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,5 +7,12 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@
+override_dh_auto_test:
+ifeq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
+ dh_auto_test
+ export PATH="$(shell pwd)/fsck:$$PATH"; cd tests; ./test_fsck.sh
+ rm tests/exfat.img
+endif
+
override_dh_installchangelogs:
dh_installchangelogs NEWS
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..c951620
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,7 @@
+Tests: fsck
+Depends: @
+Restrictions: allow-stderr
+
+Tests: create-files
+Depends: @
+Restrictions: isolation-machine, needs-root
diff --git a/debian/tests/create-files b/debian/tests/create-files
new file mode 100644
index 0000000..d7e89d6
--- /dev/null
+++ b/debian/tests/create-files
@@ -0,0 +1,35 @@
+#!/bin/bash
+
+# Original source:
+# https://github.com/exfatprogs/exfatprogs/blob/1.2.4/.github/workflows/c-cpp.yml#L37
+
+set -e
+
+mkdir "${AUTOPKGTEST_TMP}/mnt"
+truncate -s 10G "${AUTOPKGTEST_TMP}/test.img"
+
+dev=$(losetup --show -f "${AUTOPKGTEST_TMP}/test.img")
+mkfs.exfat ${dev}
+
+mount -t exfat ${dev} "${AUTOPKGTEST_TMP}/mnt"
+cd "${AUTOPKGTEST_TMP}/mnt"
+
+i=1;while [ $i -le 10000 ];do touch file$i;if [ $? != 0 ]; then exit 1; fi; i=$(($i + 1));done
+sync
+rm -rf *
+
+i=1;while [ $i -le 10000 ];do mkdir dir$i;if [ $? != 0 ]; then exit 1; fi; i=$(($i + 1));done
+sync
+rm -rf *
+
+i=1;while [ $i -le 10000 ];do touch file$i;if [ $? != 0 ]; then exit 1; fi; i=$(($i + 1));done
+i=1;while [ $i -le 10000 ];do mkdir dir$i;if [ $? != 0 ]; then exit 1; fi; i=$(($i + 1));done
+sync
+
+fsck.exfat ${dev}
+find . -delete
+fsck.exfat ${dev}
+
+cd -
+umount ${dev}
+losetup -d ${dev}
diff --git a/debian/tests/fsck b/debian/tests/fsck
new file mode 100755
index 0000000..bbb998f
--- /dev/null
+++ b/debian/tests/fsck
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+set -e
+
+export TESTDIR="${AUTOPKGTEST_TMP}/fsck_tests"
+
+cp -r ./tests "$TESTDIR"
+cd "$TESTDIR"
+
+./test_fsck.sh
diff --git a/debian/watch b/debian/watch
index 429f27f..5b30c4a 100644
--- a/debian/watch
+++ b/debian/watch
@@ -2,4 +2,4 @@ version=4
opts="searchmode=plain,pgpmode=auto,\
filenamemangle=s%v?@ANY_VERSION@%@PACKAGE@-$1.tar.xz%" \
https://api.github.com/repos/exfatprogs/exfatprogs/releases?per_page=50 \
-https://api.github.com/repos/[^/]+/[^/]+/tarball/v?@ANY_VERSION@ \ No newline at end of file
+https://github.com/[^/]+/[^/]+/releases/download/(?:[\d\.]+)/@PACKAGE@-@ANY_VERSION@.tar.xz \ No newline at end of file