summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:50:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:50:18 +0000
commita8f6774ad2693bebb5c45b437815a3dfc777627f (patch)
treeadcb37c02a764490d40305ba8c4c25e82d3b8752 /debian/patches
parentAdding upstream version 4.12.1. (diff)
downloadfence-agents-a8f6774ad2693bebb5c45b437815a3dfc777627f.tar.xz
fence-agents-a8f6774ad2693bebb5c45b437815a3dfc777627f.zip
Adding debian version 4.12.1-1.debian/4.12.1-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/disable-network-access27
-rw-r--r--debian/patches/enable-zvm-agent17
-rw-r--r--debian/patches/fence-virt-key17
-rw-r--r--debian/patches/logging-warn-deprecated65
-rw-r--r--debian/patches/series6
-rw-r--r--debian/patches/spelling37
-rw-r--r--debian/patches/systemd-syslog-target16
7 files changed, 185 insertions, 0 deletions
diff --git a/debian/patches/disable-network-access b/debian/patches/disable-network-access
new file mode 100644
index 0000000..772f614
--- /dev/null
+++ b/debian/patches/disable-network-access
@@ -0,0 +1,27 @@
+Description: Disable Internet access during build
+ Agents try to resolve and access hostname 'test', use
+ 127.0.0.1 instead.
+ .
+ Disable testing for ovh as it tries to access SOAP service
+ on www.ovh.com.
+Author: Valentin Vidic <Valentin.Vidic@CARNet.hr>
+Bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=849336
+Last-Update: 2017-12-03
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/agents/Makefile.am
++++ b/agents/Makefile.am
+@@ -67,11 +67,11 @@
+ FENCE_TEST_ARGS = \
+ login=test\n\
+ passwd=test\n\
+-ipaddr=test\n\
++ipaddr=127.0.0.1\n\
+ port=1\n\
+ managed=1\n\
+ devices=test\n\
+-session_url=http://test\n\
++session_url=http://127.0.0.1\n\
+ email=test@test.te\n\
+ ping_targets=localhost
+
diff --git a/debian/patches/enable-zvm-agent b/debian/patches/enable-zvm-agent
new file mode 100644
index 0000000..4b50e40
--- /dev/null
+++ b/debian/patches/enable-zvm-agent
@@ -0,0 +1,17 @@
+Description: Leave zvm enabled
+ Remove agent after bookworm release.
+Author: Valentin Vidic <vvidic@debian.org>
+Last-Update: 2023-01-14
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/configure.ac
++++ b/configure.ac
+@@ -196,7 +196,7 @@
+ fi
+
+ FENCE_ZVM=0
+-if echo "$AGENTS_LIST" | grep -q -E "zvm( |$)"; then
++if echo "$AGENTS_LIST" | grep -q -E "all|zvm( |$)"; then
+ FENCE_ZVM=1
+ fi
+
diff --git a/debian/patches/fence-virt-key b/debian/patches/fence-virt-key
new file mode 100644
index 0000000..8b517eb
--- /dev/null
+++ b/debian/patches/fence-virt-key
@@ -0,0 +1,17 @@
+Description: Update path for key file
+ Daemon does not start if the key file is missing.
+Author: Valentin Vidic <vvidic@debian.org>
+Last-Update: 2023-01-14
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/agents/virt/config/fence_virt.conf
++++ b/agents/virt/config/fence_virt.conf
+@@ -5,7 +5,7 @@
+
+ listeners {
+ multicast {
+- key_file = "/etc/cluster/fence_xvm.key";
++ key_file = "/etc/fence_virt.key";
+ address = "225.0.0.12";
+ # Needed on Fedora systems
+ interface = "virbr0";
diff --git a/debian/patches/logging-warn-deprecated b/debian/patches/logging-warn-deprecated
new file mode 100644
index 0000000..77ab206
--- /dev/null
+++ b/debian/patches/logging-warn-deprecated
@@ -0,0 +1,65 @@
+Description: Replace deprecated logging function
+Author: Valentin Vidic <vvidic@debian.org>
+Last-Update: 2022-05-01
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/agents/aliyun/fence_aliyun.py
++++ b/agents/aliyun/fence_aliyun.py
+@@ -15,7 +15,7 @@
+ from aliyunsdkcore.auth.credentials import EcsRamRoleCredential
+ from aliyunsdkcore.profile import region_provider
+ except ImportError as e:
+- logging.warn("The 'aliyunsdkcore' module has been not installed or is unavailable, try to execute the command 'pip install aliyun-python-sdk-core --upgrade' to solve. error: %s" % e)
++ logging.warning("The 'aliyunsdkcore' module has been not installed or is unavailable, try to execute the command 'pip install aliyun-python-sdk-core --upgrade' to solve. error: %s" % e)
+
+
+ try:
+@@ -24,7 +24,7 @@
+ from aliyunsdkecs.request.v20140526.StopInstanceRequest import StopInstanceRequest
+ from aliyunsdkecs.request.v20140526.RebootInstanceRequest import RebootInstanceRequest
+ except ImportError as e:
+- logging.warn("The 'aliyunsdkecs' module has been not installed or is unavailable, try to execute the command 'pip install aliyun-python-sdk-ecs --upgrade' to solve. error: %s" % e)
++ logging.warning("The 'aliyunsdkecs' module has been not installed or is unavailable, try to execute the command 'pip install aliyun-python-sdk-ecs --upgrade' to solve. error: %s" % e)
+
+
+ def _send_request(conn, request):
+@@ -182,7 +182,7 @@
+ try:
+ region_provider.modify_point('Ecs', region, 'ecs.%s.aliyuncs.com' % region)
+ except Exception as e:
+- logging.warn("Failed: failed to modify endpoint to 'ecs.%s.aliyuncs.com': %s" % (region, e))
++ logging.warning("Failed: failed to modify endpoint to 'ecs.%s.aliyuncs.com': %s" % (region, e))
+
+ # Operate the fencing device
+ result = fence_action(conn, options, set_power_status, get_power_status, get_nodes_list)
+--- a/agents/compute/fence_compute.py
++++ b/agents/compute/fence_compute.py
+@@ -98,7 +98,7 @@
+ # Since it's about forcing back to a default value, there is
+ # no real worries to just consider it's still okay even if the
+ # command failed
+- logging.warn("Exception from attempt to force "
++ logging.warning("Exception from attempt to force "
+ "host back up via nova API: "
+ "%s: %s" % (e.__class__.__name__, e))
+
+--- a/agents/sbd/fence_sbd.py
++++ b/agents/sbd/fence_sbd.py
+@@ -170,7 +170,7 @@
+ if "msgwait" in line:
+ tmp_msg_timeout = int(line.split(':')[1])
+ if -1 != msg_timeout and tmp_msg_timeout != msg_timeout:
+- logging.warn(\
++ logging.warning(\
+ "sbd message timeouts differ in different devices")
+ # we only save the highest timeout
+ if tmp_msg_timeout > msg_timeout:
+@@ -418,7 +418,7 @@
+ power_timeout = int(options["--power-timeout"])
+ sbd_msg_timeout = get_msg_timeout(options)
+ if 0 < power_timeout <= sbd_msg_timeout:
+- logging.warn("power timeout needs to be \
++ logging.warning("power timeout needs to be \
+ greater then sbd message timeout")
+
+ result = fence_action(\
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..9c1a18a
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,6 @@
+disable-network-access
+spelling
+systemd-syslog-target
+logging-warn-deprecated
+enable-zvm-agent
+fence-virt-key
diff --git a/debian/patches/spelling b/debian/patches/spelling
new file mode 100644
index 0000000..c1cacd9
--- /dev/null
+++ b/debian/patches/spelling
@@ -0,0 +1,37 @@
+Description: Fix spelling errors reported by lintian
+Author: Valentin Vidic <Valentin.Vidic@CARNet.hr>
+Forwarded: not-needed
+Last-Update: 2018-02-18
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/agents/ironic/fence_ironic.py
++++ b/agents/ironic/fence_ironic.py
+@@ -110,7 +110,7 @@
+ options = check_input(device_opt, process_input(device_opt))
+
+ docs = {}
+- docs["shortdesc"] = "Fence agent for OpenStack's Ironic (Bare Metal as a service) service"
++ docs["shortdesc"] = "Fence agent for OpenStack's Ironic (Bare Metal as a service)"
+ docs["longdesc"] = "fence_ironic is a Fencing agent \
+ which can be used with machines controlled by the Ironic service. \
+ This agent calls the openstack CLI. \
+--- a/tests/data/metadata/fence_ironic.xml
++++ b/tests/data/metadata/fence_ironic.xml
+@@ -1,5 +1,5 @@
+ <?xml version="1.0" ?>
+-<resource-agent name="fence_ironic" shortdesc="Fence agent for OpenStack's Ironic (Bare Metal as a service) service" >
++<resource-agent name="fence_ironic" shortdesc="Fence agent for OpenStack's Ironic (Bare Metal as a service)" >
+ <longdesc>fence_ironic is a Fencing agent which can be used with machines controlled by the Ironic service. This agent calls the openstack CLI. WARNING! This fence agent is not intended for production use. Relying on a functional ironic service for fencing is not a good design choice.</longdesc>
+ <vendor-url>https://wiki.openstack.org/wiki/Ironic</vendor-url>
+ <parameters>
+--- a/tests/data/metadata/fence_kdump.xml
++++ b/tests/data/metadata/fence_kdump.xml
+@@ -3,7 +3,7 @@
+ <longdesc>fence_kdump is an I/O fencing agent to be used with the kdump
+ crash recovery service. When the fence_kdump agent is invoked,
+ it will listen for a message from the failed node that acknowledges
+-that the failed node it executing the kdump crash kernel.
++that the failed node is executing the kdump crash kernel.
+ Note that fence_kdump is not a replacement for traditional
+ fencing methods. The fence_kdump agent can only detect that a
+ node has entered the kdump crash recovery service. This allows the
diff --git a/debian/patches/systemd-syslog-target b/debian/patches/systemd-syslog-target
new file mode 100644
index 0000000..f8bf295
--- /dev/null
+++ b/debian/patches/systemd-syslog-target
@@ -0,0 +1,16 @@
+Description: Remove syslog target from systemd service file
+ Fixes systemd-service-file-refers-to-obsolete-target lintian warning
+Author: Valentin Vidic <vvidic@debian.org>
+Last-Update: 2022-05-01
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/agents/virt/fence_virtd.service.in
++++ b/agents/virt/fence_virtd.service.in
+@@ -5,7 +5,6 @@
+
+ After=basic.target
+ After=network.target
+-After=syslog.target
+ After=libvirtd.service
+ After=corosync.service
+