summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:50:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:50:17 +0000
commit86ed03f8adee56c050c73018537371c230a664a6 (patch)
treeeae3d04cdf1c49848e5a671327ab38297f4acb0d /lib/Makefile.am
parentInitial commit. (diff)
downloadfence-agents-upstream.tar.xz
fence-agents-upstream.zip
Adding upstream version 4.12.1.upstream/4.12.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--lib/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..0fe7096
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,34 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+TARGET = fencing.py fencing_snmp.py azure_fence.py
+
+if BUILD_XENAPILIB
+TARGET += XenAPI.py
+endif
+
+SRC = fencing.py.py fencing_snmp.py.py XenAPI.py.py azure_fence.py.py check_used_options.py
+
+XSL = fence2man.xsl fence2rng.xsl fence2wiki.xsl
+
+FASRNG = fence.rng.head fence.rng.tail metadata.rng
+
+EXTRA_DIST = $(SRC) $(XSL) $(FASRNG)
+
+fencelibdir = ${FENCEAGENTSLIBDIR}
+
+fencelib_DATA = $(TARGET)
+
+rngdir = ${CLUSTERDATA}/relaxng
+
+rng_DATA = $(XSL) $(FASRNG)
+
+azure_fence.py: fencing.py
+fencing_snmp.py: fencing.py
+check_used_options.py: fencing.py
+
+include $(top_srcdir)/make/fencebuild.mk
+
+xml-check: all
+xml-upload: all
+
+clean-man: