summaryrefslogtreecommitdiffstats
path: root/third_party/rust/askama/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /third_party/rust/askama/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/askama/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/askama/Cargo.toml b/third_party/rust/askama/Cargo.toml
new file mode 100644
index 0000000000..f566aa4eba
--- /dev/null
+++ b/third_party/rust/askama/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "askama"
+version = "0.11.1"
+description = "Type-safe, compiled Jinja-like templates for Rust"
+homepage = "https://github.com/djc/askama"
+documentation = "https://docs.rs/askama"
+readme = "../README.md"
+keywords = ["markup", "template", "jinja2", "html"]
+categories = ["template-engine"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/djc/askama"
+[package.metadata.docs.rs]
+features = ["config", "humansize", "num-traits", "serde-json", "serde-yaml"]
+[dependencies.askama_derive]
+version = "0.11.2"
+
+[dependencies.askama_escape]
+version = "0.10"
+
+[dependencies.askama_shared]
+version = "0.12.1"
+default-features = false
+
+[features]
+config = ["askama_derive/config", "askama_shared/config"]
+default = ["config", "humansize", "num-traits", "urlencode"]
+humansize = ["askama_shared/humansize"]
+markdown = ["askama_shared/markdown"]
+mime = []
+mime_guess = []
+num-traits = ["askama_shared/num-traits"]
+serde-json = ["askama_derive/json", "askama_shared/json"]
+serde-yaml = ["askama_derive/yaml", "askama_shared/yaml"]
+urlencode = ["askama_shared/percent-encoding"]
+with-actix-web = ["askama_derive/actix-web"]
+with-axum = ["askama_derive/axum"]
+with-gotham = ["askama_derive/gotham"]
+with-mendes = ["askama_derive/mendes"]
+with-rocket = ["askama_derive/rocket"]
+with-tide = ["askama_derive/tide"]
+with-warp = ["askama_derive/warp"]
+[badges.maintenance]
+status = "actively-developed"