summaryrefslogtreecommitdiffstats
path: root/third_party/rust/data-encoding/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /third_party/rust/data-encoding/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/data-encoding/Cargo.toml')
-rw-r--r--third_party/rust/data-encoding/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/data-encoding/Cargo.toml b/third_party/rust/data-encoding/Cargo.toml
new file mode 100644
index 0000000000..36294764a9
--- /dev/null
+++ b/third_party/rust/data-encoding/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.46"
+name = "data-encoding"
+version = "2.3.3"
+authors = ["Julien Cretin <git@ia0.eu>"]
+include = [
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+ "src/lib.rs",
+]
+description = "Efficient and customizable data-encoding functions like base64, base32, and hex"
+documentation = "https://docs.rs/data-encoding"
+readme = "README.md"
+keywords = [
+ "no_std",
+ "base64",
+ "base32",
+ "hex",
+]
+categories = [
+ "encoding",
+ "no-std",
+]
+license = "MIT"
+repository = "https://github.com/ia0/data-encoding"
+
+[features]
+alloc = []
+default = ["std"]
+std = ["alloc"]