summaryrefslogtreecommitdiffstats
path: root/third_party/rust/midir/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/midir/Cargo.toml97
1 files changed, 97 insertions, 0 deletions
diff --git a/third_party/rust/midir/Cargo.toml b/third_party/rust/midir/Cargo.toml
new file mode 100644
index 0000000000..f84a0a79cb
--- /dev/null
+++ b/third_party/rust/midir/Cargo.toml
@@ -0,0 +1,97 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "midir"
+version = "0.7.0"
+authors = ["Patrick Reisert"]
+description = "A cross-platform, realtime MIDI processing library, inspired by RtMidi."
+readme = "README.md"
+keywords = [
+ "midi",
+ "audio",
+ "music",
+ "sound",
+]
+categories = [
+ "multimedia::audio",
+ "api-bindings",
+]
+license = "MIT"
+repository = "https://github.com/Boddlnagg/midir"
+
+[dependencies]
+bitflags = "1.2"
+memalloc = "0.1.0"
+
+[dependencies.jack-sys]
+version = "0.1.0"
+optional = true
+
+[dependencies.libc]
+version = "0.2.21"
+optional = true
+
+[dependencies.winrt]
+version = "0.7.0"
+optional = true
+
+[features]
+avoid_timestamping = []
+default = []
+jack = [
+ "jack-sys",
+ "libc",
+]
+
+[target."cfg(target_arch = \"wasm32\")".dependencies]
+js-sys = "0.3"
+wasm-bindgen = "0.2"
+
+[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
+version = "0.3"
+features = [
+ "Event",
+ "Navigator",
+ "Window",
+ "MidiAccess",
+ "MidiInput",
+ "MidiInputMap",
+ "MidiMessageEvent",
+ "MidiOptions",
+ "MidiOutput",
+ "MidiOutputMap",
+ "MidiPort",
+ "MidiPortType",
+]
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies]
+wasm-bindgen-test = "0.2"
+
+[target."cfg(target_os = \"linux\")".dependencies]
+alsa = "0.7"
+libc = "0.2.21"
+
+[target."cfg(target_os = \"macos\")".dependencies]
+coremidi = "0.6.0"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = [
+ "mmsystem",
+ "mmeapi",
+]
+
+[workspace]
+members = [
+ ".",
+ "examples/browser",
+]