summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ron/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ron/Cargo.toml')
-rw-r--r--third_party/rust/ron/Cargo.toml63
1 files changed, 63 insertions, 0 deletions
diff --git a/third_party/rust/ron/Cargo.toml b/third_party/rust/ron/Cargo.toml
new file mode 100644
index 0000000000..c44d06a521
--- /dev/null
+++ b/third_party/rust/ron/Cargo.toml
@@ -0,0 +1,63 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56.0"
+name = "ron"
+version = "0.8.0"
+authors = [
+ "Christopher Durham <cad97@cad97.com>",
+ "Dzmitry Malyshau <kvarkus@gmail.com>",
+ "Thomas Schaller <torkleyy@gmail.com>",
+ "Juniper Langenstein <juniper.langenstein@helsinki.fi>",
+]
+description = "Rusty Object Notation"
+homepage = "https://github.com/ron-rs/ron"
+documentation = "https://docs.rs/ron/"
+readme = "README.md"
+keywords = [
+ "parser",
+ "serde",
+ "serialization",
+]
+categories = ["encoding"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/ron-rs/ron"
+resolver = "2"
+
+[dependencies.base64]
+version = "0.13"
+
+[dependencies.bitflags]
+version = "1.3.2"
+
+[dependencies.indexmap]
+version = "1.9.1"
+features = ["serde-1"]
+optional = true
+
+[dependencies.serde]
+version = "1.0.60"
+features = ["serde_derive"]
+
+[dev-dependencies.option_set]
+version = "0.1"
+
+[dev-dependencies.serde_bytes]
+version = "0.11"
+
+[dev-dependencies.serde_json]
+version = "1"
+
+[features]
+default = []
+integer128 = []