summaryrefslogtreecommitdiffstats
path: root/third_party/rust/unicode-width/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/unicode-width/Cargo.toml')
-rw-r--r--third_party/rust/unicode-width/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/third_party/rust/unicode-width/Cargo.toml b/third_party/rust/unicode-width/Cargo.toml
new file mode 100644
index 0000000000..77aded9fc3
--- /dev/null
+++ b/third_party/rust/unicode-width/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "unicode-width"
+version = "0.1.10"
+authors = [
+ "kwantam <kwantam@gmail.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+]
+exclude = [
+ "target/*",
+ "Cargo.lock",
+]
+description = """
+Determine displayed width of `char` and `str` types
+according to Unicode Standard Annex #11 rules.
+"""
+homepage = "https://github.com/unicode-rs/unicode-width"
+documentation = "https://unicode-rs.github.io/unicode-width"
+readme = "README.md"
+keywords = [
+ "text",
+ "width",
+ "unicode",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/unicode-rs/unicode-width"
+
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.std]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-std"
+
+[features]
+bench = []
+default = []
+no_std = []
+rustc-dep-of-std = [
+ "std",
+ "core",
+ "compiler_builtins",
+]