summaryrefslogtreecommitdiffstats
path: root/browser/components/uitour/test/browser_UITour_showNewTab.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /browser/components/uitour/test/browser_UITour_showNewTab.js
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'browser/components/uitour/test/browser_UITour_showNewTab.js')
-rw-r--r--browser/components/uitour/test/browser_UITour_showNewTab.js25
1 files changed, 25 insertions, 0 deletions
diff --git a/browser/components/uitour/test/browser_UITour_showNewTab.js b/browser/components/uitour/test/browser_UITour_showNewTab.js
new file mode 100644
index 0000000000..386de3920f
--- /dev/null
+++ b/browser/components/uitour/test/browser_UITour_showNewTab.js
@@ -0,0 +1,25 @@
+"use strict";
+
+var gTestTab;
+var gContentAPI;
+
+add_task(setup_UITourTest);
+
+// Test that we can switch to about:newtab
+add_UITour_task(async function test_aboutNewTab() {
+ let newTabLoaded = BrowserTestUtils.browserLoaded(
+ gBrowser.selectedBrowser,
+ false,
+ "about:newtab"
+ );
+ info("Showing about:newtab");
+ await gContentAPI.showNewTab();
+ info("Waiting for about:newtab to load");
+ await newTabLoaded;
+ is(
+ gBrowser.selectedBrowser.currentURI.spec,
+ "about:newtab",
+ "Loaded about:newtab"
+ );
+ ok(gURLBar.focused, "Address bar gets focus");
+});