summaryrefslogtreecommitdiffstats
path: root/build/binary-location.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /build/binary-location.mk
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/binary-location.mk')
-rw-r--r--build/binary-location.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/build/binary-location.mk b/build/binary-location.mk
new file mode 100644
index 0000000000..19ae4b55f3
--- /dev/null
+++ b/build/binary-location.mk
@@ -0,0 +1,19 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+# finds the location of the browser and puts it in the variable $(browser_path)
+
+ifneq (,$(filter WINNT,$(OS_ARCH)))
+program = $(MOZ_APP_NAME)$(BIN_SUFFIX)
+else
+program = $(MOZ_APP_NAME)-bin$(BIN_SUFFIX)
+endif
+
+TARGET_DIST = $(TARGET_DEPTH)/dist
+
+ifeq ($(OS_ARCH),Darwin)
+browser_path = $(TARGET_DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/$(program)
+else
+browser_path = $(TARGET_DIST)/bin/$(program)
+endif