summaryrefslogtreecommitdiffstats
path: root/build/rust/libloading
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
commit59203c63bb777a3bacec32fb8830fba33540e809 (patch)
tree58298e711c0ff0575818c30485b44a2f21bf28a0 /build/rust/libloading
parentAdding upstream version 126.0.1. (diff)
downloadfirefox-59203c63bb777a3bacec32fb8830fba33540e809.tar.xz
firefox-59203c63bb777a3bacec32fb8830fba33540e809.zip
Adding upstream version 127.0.upstream/127.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/libloading')
-rw-r--r--build/rust/libloading/Cargo.toml10
-rw-r--r--build/rust/libloading/lib.rs4
2 files changed, 14 insertions, 0 deletions
diff --git a/build/rust/libloading/Cargo.toml b/build/rust/libloading/Cargo.toml
new file mode 100644
index 0000000000..18385bc7ac
--- /dev/null
+++ b/build/rust/libloading/Cargo.toml
@@ -0,0 +1,10 @@
+[package]
+name = "libloading"
+version = "0.7.999"
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.libloading]
+version = "0.8.3"
diff --git a/build/rust/libloading/lib.rs b/build/rust/libloading/lib.rs
new file mode 100644
index 0000000000..790eef042c
--- /dev/null
+++ b/build/rust/libloading/lib.rs
@@ -0,0 +1,4 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+pub use libloading::*;