summaryrefslogtreecommitdiffstats
path: root/build/rust/terminal_size
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /build/rust/terminal_size
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/terminal_size')
-rw-r--r--build/rust/terminal_size/Cargo.toml8
-rw-r--r--build/rust/terminal_size/lib.rs26
2 files changed, 34 insertions, 0 deletions
diff --git a/build/rust/terminal_size/Cargo.toml b/build/rust/terminal_size/Cargo.toml
new file mode 100644
index 0000000000..f787ebdd15
--- /dev/null
+++ b/build/rust/terminal_size/Cargo.toml
@@ -0,0 +1,8 @@
+[package]
+name = "terminal_size"
+version = "0.3.999"
+edition = "2018"
+license = "MIT OR Apache-2.0"
+
+[lib]
+path = "lib.rs"
diff --git a/build/rust/terminal_size/lib.rs b/build/rust/terminal_size/lib.rs
new file mode 100644
index 0000000000..e2e6512604
--- /dev/null
+++ b/build/rust/terminal_size/lib.rs
@@ -0,0 +1,26 @@
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
+#[derive(Debug, Clone, Copy, PartialEq, Eq, PartialOrd, Ord)]
+pub struct Width(pub u16);
+#[derive(Debug, Clone, Copy, PartialEq, Eq, PartialOrd, Ord)]
+pub struct Height(pub u16);
+
+pub fn terminal_size() -> Option<(Width, Height)> {
+ Some((Width(80), Height(25)))
+}
+
+#[cfg(unix)]
+pub fn terminal_size_using_fd(_fd: std::os::unix::io::RawFd) -> Option<(Width, Height)> {
+ Some((Width(80), Height(25)))
+}
+
+#[cfg(windows)]
+pub fn terminal_size_using_handle(
+ _handle: std::os::windows::io::RawHandle,
+) -> Option<(Width, Height)> {
+ Some((Width(80), Height(25)))
+}