summaryrefslogtreecommitdiffstats
path: root/build/win32/moz.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /build/win32/moz.build
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/win32/moz.build')
-rw-r--r--build/win32/moz.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/build/win32/moz.build b/build/win32/moz.build
new file mode 100644
index 0000000000..d8d61a22db
--- /dev/null
+++ b/build/win32/moz.build
@@ -0,0 +1,32 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+TEST_DIRS += ["crashinjectdll"]
+
+if CONFIG["ENABLE_TESTS"]:
+ Program("crashinject")
+ SOURCES += [
+ "crashinject.cpp",
+ ]
+ USE_STATIC_LIBS = True
+
+NO_PGO = True
+
+# See comment about *-windows-gnu targets in config/makefiles/rust.mk
+if CONFIG["CC_TYPE"] == "clang":
+ GeneratedFile(
+ "libgcc.a",
+ "libgcc_eh.a",
+ "libpthread.a",
+ script="dummy_libs.py",
+ flags=["libgcc_eh.a", "libpthread.a"],
+ )
+
+
+if CONFIG["WIN32_REDIST_DIR"] and CONFIG["COMPILE_ENVIRONMENT"]:
+ for f in ["MSVC_C_RUNTIME_DLL", "MSVC_C_RUNTIME_1_DLL", "MSVC_CXX_RUNTIME_DLL"]:
+ if CONFIG[f]:
+ FINAL_TARGET_FILES += ["%%%s/%s" % (CONFIG["WIN32_REDIST_DIR"], CONFIG[f])]