summaryrefslogtreecommitdiffstats
path: root/config/makefiles/rust.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:33 +0000
commit086c044dc34dfc0f74fbe41f4ecb402b2cd34884 (patch)
treea4f824bd33cb075dd5aa3eb5a0a94af221bbe83a /config/makefiles/rust.mk
parentAdding debian version 124.0.1-1. (diff)
downloadfirefox-086c044dc34dfc0f74fbe41f4ecb402b2cd34884.tar.xz
firefox-086c044dc34dfc0f74fbe41f4ecb402b2cd34884.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'config/makefiles/rust.mk')
-rw-r--r--config/makefiles/rust.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
index 9e3d5256b9..b10594f5cb 100644
--- a/config/makefiles/rust.mk
+++ b/config/makefiles/rust.mk
@@ -252,6 +252,12 @@ ifeq ($(OS_ARCH), Darwin)
ifdef MACOS_SDK_DIR
export COREAUDIO_SDK_PATH=$(MACOS_SDK_DIR)
endif
+ifdef IPHONEOS_SDK_DIR
+export COREAUDIO_SDK_PATH=$(IPHONEOS_SDK_DIR)
+# export for build/macosx/xcrun
+export IPHONEOS_SDK_DIR
+PATH := $(topsrcdir)/build/macosx:$(PATH)
+endif
endif
ifndef RUSTC_BOOTSTRAP