summaryrefslogtreecommitdiffstats
path: root/config/makefiles/rust.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /config/makefiles/rust.mk
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-upstream/125.0.1.tar.xz
firefox-upstream/125.0.1.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'config/makefiles/rust.mk')
-rw-r--r--config/makefiles/rust.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
index 9e3d5256b9..b10594f5cb 100644
--- a/config/makefiles/rust.mk
+++ b/config/makefiles/rust.mk
@@ -252,6 +252,12 @@ ifeq ($(OS_ARCH), Darwin)
ifdef MACOS_SDK_DIR
export COREAUDIO_SDK_PATH=$(MACOS_SDK_DIR)
endif
+ifdef IPHONEOS_SDK_DIR
+export COREAUDIO_SDK_PATH=$(IPHONEOS_SDK_DIR)
+# export for build/macosx/xcrun
+export IPHONEOS_SDK_DIR
+PATH := $(topsrcdir)/build/macosx:$(PATH)
+endif
endif
ifndef RUSTC_BOOTSTRAP