summaryrefslogtreecommitdiffstats
path: root/debian/dh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:49:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:49:03 +0000
commitf7359bb5d4af5721623ec8a5aa8b13d2ebce6a98 (patch)
tree45b8fb78a492d1e85f34e2289e41536f0be60c0a /debian/dh
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-f7359bb5d4af5721623ec8a5aa8b13d2ebce6a98.tar.xz
firefox-f7359bb5d4af5721623ec8a5aa8b13d2ebce6a98.zip
Adding debian version 124.0.1-1.debian/124.0.1-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/dh')
-rwxr-xr-xdebian/dh25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/dh b/debian/dh
new file mode 100755
index 0000000000..5b43536dd4
--- /dev/null
+++ b/debian/dh
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# Wrapper around dh to enable parallelism in debian/rules if not already
+# enabled.
+
+case "$MAKEFLAGS" in
+*-j*)
+ # Already enabled, do nothing.
+ ;;
+*)
+ parallel=
+ for opt in "$DEB_BUILD_OPTIONS"; do
+ case "$opt" in
+ parallel=*)
+ parallel=${opt#parallel=}
+ ;;
+ esac
+ done
+ if [ -n "$parallel" ]; then
+ export MAKEFLAGS="-j$parallel${MAKEFLAGS:+ $MAKEFLAGS}"
+ fi
+ ;;
+esac
+
+exec dh "$@"