summaryrefslogtreecommitdiffstats
path: root/docshell/test/browser/browser_bug1206879.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /docshell/test/browser/browser_bug1206879.js
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-40a355a42d4a9444dc753c04c6608dade2f06a23.tar.xz
firefox-40a355a42d4a9444dc753c04c6608dade2f06a23.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docshell/test/browser/browser_bug1206879.js')
-rw-r--r--docshell/test/browser/browser_bug1206879.js4
1 files changed, 2 insertions, 2 deletions
diff --git a/docshell/test/browser/browser_bug1206879.js b/docshell/test/browser/browser_bug1206879.js
index 38e17633b8..114a3c448b 100644
--- a/docshell/test/browser/browser_bug1206879.js
+++ b/docshell/test/browser/browser_bug1206879.js
@@ -14,7 +14,7 @@ add_task(async function () {
let webprogress = content.docShell.QueryInterface(Ci.nsIWebProgress);
let locationChangeCount = 0;
let listener = {
- onLocationChange(aWebProgress, aRequest, aLocation, aFlags) {
+ onLocationChange(aWebProgress, aRequest, aLocation) {
info("onLocationChange: " + aLocation.spec);
locationChangeCount++;
this.resolve();
@@ -24,7 +24,7 @@ add_task(async function () {
"nsISupportsWeakReference",
]),
};
- let locationPromise = new Promise((resolve, reject) => {
+ let locationPromise = new Promise(resolve => {
listener.resolve = resolve;
});
webprogress.addProgressListener(