summaryrefslogtreecommitdiffstats
path: root/dom/html/FetchPriority.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/html/FetchPriority.h
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/html/FetchPriority.h')
-rw-r--r--dom/html/FetchPriority.h36
1 files changed, 36 insertions, 0 deletions
diff --git a/dom/html/FetchPriority.h b/dom/html/FetchPriority.h
new file mode 100644
index 0000000000..5719577771
--- /dev/null
+++ b/dom/html/FetchPriority.h
@@ -0,0 +1,36 @@
+/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* vim: set ts=8 sts=2 et sw=2 tw=80: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef mozilla_dom_FetchPriority_h
+#define mozilla_dom_FetchPriority_h
+
+#include <cstdint>
+
+namespace mozilla {
+class LazyLogModule;
+
+namespace dom {
+
+enum class RequestPriority : uint8_t;
+
+// <https://html.spec.whatwg.org/multipage/urls-and-fetching.html#fetch-priority-attributes>.
+enum class FetchPriority : uint8_t { High, Low, Auto };
+
+FetchPriority ToFetchPriority(RequestPriority aRequestPriority);
+
+// @param aSupportsPriority see <nsISupportsPriority.idl>.
+void LogPriorityMapping(LazyLogModule& aLazyLogModule,
+ FetchPriority aFetchPriority,
+ int32_t aSupportsPriority);
+
+extern const char* kFetchPriorityAttributeValueHigh;
+extern const char* kFetchPriorityAttributeValueLow;
+extern const char* kFetchPriorityAttributeValueAuto;
+
+} // namespace dom
+} // namespace mozilla
+
+#endif // mozilla_dom_FetchPriority_h