summaryrefslogtreecommitdiffstats
path: root/dom/html/HTMLProgressElement.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/html/HTMLProgressElement.h
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/html/HTMLProgressElement.h')
-rw-r--r--dom/html/HTMLProgressElement.h57
1 files changed, 57 insertions, 0 deletions
diff --git a/dom/html/HTMLProgressElement.h b/dom/html/HTMLProgressElement.h
new file mode 100644
index 0000000000..e0de536282
--- /dev/null
+++ b/dom/html/HTMLProgressElement.h
@@ -0,0 +1,57 @@
+/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* vim: set ts=8 sts=2 et sw=2 tw=80: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef mozilla_dom_HTMLProgressElement_h
+#define mozilla_dom_HTMLProgressElement_h
+
+#include "mozilla/Attributes.h"
+#include "nsGenericHTMLElement.h"
+#include "nsAttrValue.h"
+#include "nsAttrValueInlines.h"
+#include <algorithm>
+
+namespace mozilla::dom {
+
+class HTMLProgressElement final : public nsGenericHTMLElement {
+ public:
+ explicit HTMLProgressElement(
+ already_AddRefed<mozilla::dom::NodeInfo>&& aNodeInfo);
+
+ nsresult Clone(dom::NodeInfo*, nsINode** aResult) const override;
+
+ bool ParseAttribute(int32_t aNamespaceID, nsAtom* aAttribute,
+ const nsAString& aValue,
+ nsIPrincipal* aMaybeScriptedPrincipal,
+ nsAttrValue& aResult) override;
+ void AfterSetAttr(int32_t aNameSpaceID, nsAtom* aName,
+ const nsAttrValue* aValue, const nsAttrValue* aOldValue,
+ nsIPrincipal* aSubjectPrincipal, bool aNotify) override;
+
+ // WebIDL
+ double Value() const;
+ void SetValue(double aValue, ErrorResult& aRv) {
+ SetDoubleAttr(nsGkAtoms::value, aValue, aRv);
+ }
+ double Max() const;
+ void SetMax(double aValue, ErrorResult& aRv) {
+ // https://html.spec.whatwg.org/multipage/form-elements.html#dom-progress-max
+ // The max IDL attribute must reflect the content attribute of the same
+ // name, limited to only positive numbers.
+ SetDoubleAttr<Reflection::OnlyPositive>(nsGkAtoms::max, aValue, aRv);
+ }
+ double Position() const;
+
+ NS_IMPL_FROMNODE_HTML_WITH_TAG(HTMLProgressElement, progress);
+
+ protected:
+ virtual ~HTMLProgressElement();
+
+ JSObject* WrapNode(JSContext*, JS::Handle<JSObject*> aGivenProto) override;
+};
+
+} // namespace mozilla::dom
+
+#endif // mozilla_dom_HTMLProgressElement_h