summaryrefslogtreecommitdiffstats
path: root/dom/tests/browser/browser_persist_image_accept.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /dom/tests/browser/browser_persist_image_accept.js
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-adbda400be353e676059e335c3c0aaf99e719475.tar.xz
firefox-adbda400be353e676059e335c3c0aaf99e719475.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/tests/browser/browser_persist_image_accept.js')
-rw-r--r--dom/tests/browser/browser_persist_image_accept.js4
1 files changed, 2 insertions, 2 deletions
diff --git a/dom/tests/browser/browser_persist_image_accept.js b/dom/tests/browser/browser_persist_image_accept.js
index b4648a51ec..21a2096b9d 100644
--- a/dom/tests/browser/browser_persist_image_accept.js
+++ b/dom/tests/browser/browser_persist_image_accept.js
@@ -9,7 +9,7 @@ const TEST_PATH = getRootDirectory(gTestPath).replace(
);
var MockFilePicker = SpecialPowers.MockFilePicker;
-MockFilePicker.init(window);
+MockFilePicker.init(window.browsingContext);
registerCleanupFunction(async function () {
info("Running the cleanup code");
@@ -100,7 +100,7 @@ add_task(async function test_image_download() {
});
let httpOnModifyPromise = TestUtils.topicObserved(
"http-on-modify-request",
- (s, t, d) => {
+ s => {
let channel = s.QueryInterface(Ci.nsIChannel);
let uri = channel.URI && channel.URI.spec;
if (!uri.endsWith("dummy.png")) {