summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
commit59203c63bb777a3bacec32fb8830fba33540e809 (patch)
tree58298e711c0ff0575818c30485b44a2f21bf28a0 /dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts
parentAdding upstream version 126.0.1. (diff)
downloadfirefox-59203c63bb777a3bacec32fb8830fba33540e809.tar.xz
firefox-59203c63bb777a3bacec32fb8830fba33540e809.zip
Adding upstream version 127.0.upstream/127.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts')
-rw-r--r--dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts69
1 files changed, 69 insertions, 0 deletions
diff --git a/dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts b/dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts
index 9717ba3ecf..ea6ed5e42f 100644
--- a/dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts
+++ b/dom/webgpu/tests/cts/checkout/src/unittests/serialization.spec.ts
@@ -16,6 +16,8 @@ import {
} from '../webgpu/util/compare.js';
import { kValue } from '../webgpu/util/constants.js';
import {
+ abstractFloat,
+ abstractInt,
bool,
deserializeValue,
f16,
@@ -61,6 +63,18 @@ g.test('value').fn(t => {
u8(kValue.u8.max - 1),
u8(kValue.u8.max - 0),
+ abstractInt(kValue.i64.negative.min),
+ abstractInt(kValue.i64.negative.min + 1n),
+ abstractInt(kValue.i64.negative.min + 2n),
+ abstractInt(kValue.i64.negative.max - 2n),
+ abstractInt(kValue.i64.negative.max - 1n),
+ abstractInt(kValue.i64.positive.min),
+ abstractInt(kValue.i64.positive.min + 1n),
+ abstractInt(kValue.i64.positive.min + 2n),
+ abstractInt(kValue.i64.positive.max - 2n),
+ abstractInt(kValue.i64.positive.max - 1n),
+ abstractInt(kValue.i64.positive.max),
+
i32(kValue.i32.negative.min + 0),
i32(kValue.i32.negative.min + 1),
i32(kValue.i32.negative.min + 2),
@@ -97,6 +111,21 @@ g.test('value').fn(t => {
i8(kValue.i8.positive.max - 1),
i8(kValue.i8.positive.max - 0),
+ abstractFloat(0),
+ abstractFloat(-0),
+ abstractFloat(1),
+ abstractFloat(-1),
+ abstractFloat(0.5),
+ abstractFloat(-0.5),
+ abstractFloat(kValue.f64.positive.max),
+ abstractFloat(kValue.f64.positive.min),
+ abstractFloat(kValue.f64.positive.subnormal.max),
+ abstractFloat(kValue.f64.positive.subnormal.min),
+ abstractFloat(kValue.f64.negative.subnormal.max),
+ abstractFloat(kValue.f64.negative.subnormal.min),
+ abstractFloat(kValue.f64.positive.infinity),
+ abstractFloat(kValue.f64.negative.infinity),
+
f32(0),
f32(-0),
f32(1),
@@ -139,6 +168,13 @@ g.test('value').fn(t => {
[0.0, 1.0],
[2.0, 3.0],
],
+ abstractFloat
+ ),
+ toMatrix(
+ [
+ [0.0, 1.0],
+ [2.0, 3.0],
+ ],
f32
),
toMatrix(
@@ -153,6 +189,13 @@ g.test('value').fn(t => {
[0.0, 1.0, 2.0, 3.0],
[4.0, 5.0, 6.0, 7.0],
],
+ abstractFloat
+ ),
+ toMatrix(
+ [
+ [0.0, 1.0, 2.0, 3.0],
+ [4.0, 5.0, 6.0, 7.0],
+ ],
f32
),
toMatrix(
@@ -169,6 +212,14 @@ g.test('value').fn(t => {
[3.0, 4.0, 5.0],
[6.0, 7.0, 8.0],
],
+ abstractFloat
+ ),
+ toMatrix(
+ [
+ [0.0, 1.0, 2.0],
+ [3.0, 4.0, 5.0],
+ [6.0, 7.0, 8.0],
+ ],
f32
),
toMatrix(
@@ -186,6 +237,15 @@ g.test('value').fn(t => {
[4.0, 5.0],
[6.0, 7.0],
],
+ abstractFloat
+ ),
+ toMatrix(
+ [
+ [0.0, 1.0],
+ [2.0, 3.0],
+ [4.0, 5.0],
+ [6.0, 7.0],
+ ],
f32
),
toMatrix(
@@ -204,6 +264,15 @@ g.test('value').fn(t => {
[8.0, 9.0, 10.0, 11.0],
[12.0, 13.0, 14.0, 15.0],
],
+ abstractFloat
+ ),
+ toMatrix(
+ [
+ [0.0, 1.0, 2.0, 3.0],
+ [4.0, 5.0, 6.0, 7.0],
+ [8.0, 9.0, 10.0, 11.0],
+ [12.0, 13.0, 14.0, 15.0],
+ ],
f32
),
]) {