summaryrefslogtreecommitdiffstats
path: root/dom/webidl/DedicatedWorkerGlobalScope.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/DedicatedWorkerGlobalScope.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/DedicatedWorkerGlobalScope.webidl')
-rw-r--r--dom/webidl/DedicatedWorkerGlobalScope.webidl39
1 files changed, 39 insertions, 0 deletions
diff --git a/dom/webidl/DedicatedWorkerGlobalScope.webidl b/dom/webidl/DedicatedWorkerGlobalScope.webidl
new file mode 100644
index 0000000000..bd772b2e01
--- /dev/null
+++ b/dom/webidl/DedicatedWorkerGlobalScope.webidl
@@ -0,0 +1,39 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://www.whatwg.org/specs/web-apps/current-work/multipage/workers.html#the-workerglobalscope-common-interface
+ *
+ * © Copyright 2004-2011 Apple Computer, Inc., Mozilla Foundation, and Opera
+ * Software ASA.
+ * You are granted a license to use, reproduce and create derivative works of
+ * this document.
+ */
+
+[Global=(Worker,DedicatedWorker),
+ Exposed=DedicatedWorker]
+interface DedicatedWorkerGlobalScope : WorkerGlobalScope {
+ [Replaceable]
+ readonly attribute DOMString name;
+
+ [Throws]
+ undefined postMessage(any message, sequence<object> transfer);
+ [Throws]
+ undefined postMessage(any message, optional StructuredSerializeOptions options = {});
+
+ undefined close();
+
+ attribute EventHandler onmessage;
+ attribute EventHandler onmessageerror;
+};
+
+// https://w3c.github.io/webrtc-encoded-transform/#RTCEncodedAudioFrame-methods
+partial interface DedicatedWorkerGlobalScope {
+ [Pref="media.peerconnection.enabled",
+ Pref="media.peerconnection.scripttransform.enabled"] attribute EventHandler onrtctransform;
+};
+
+// https://html.spec.whatwg.org/multipage/imagebitmap-and-animations.html#animation-frames
+DedicatedWorkerGlobalScope includes AnimationFrameProvider;