summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ElementInternals.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/ElementInternals.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/ElementInternals.webidl')
-rw-r--r--dom/webidl/ElementInternals.webidl80
1 files changed, 80 insertions, 0 deletions
diff --git a/dom/webidl/ElementInternals.webidl b/dom/webidl/ElementInternals.webidl
new file mode 100644
index 0000000000..175d0e4e1c
--- /dev/null
+++ b/dom/webidl/ElementInternals.webidl
@@ -0,0 +1,80 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/#elementinternals
+ */
+
+[Exposed=Window]
+interface ElementInternals {
+ // Shadow root access
+ readonly attribute ShadowRoot? shadowRoot;
+
+ // Form-associated custom elements
+ [Throws]
+ undefined setFormValue((File or USVString or FormData)? value,
+ optional (File or USVString or FormData)? state);
+
+ [Throws]
+ readonly attribute HTMLFormElement? form;
+
+ [Throws]
+ undefined setValidity(optional ValidityStateFlags flags = {},
+ optional DOMString message,
+ optional HTMLElement anchor);
+ [Throws]
+ readonly attribute boolean willValidate;
+ [Throws]
+ readonly attribute ValidityState validity;
+ [Throws]
+ readonly attribute DOMString validationMessage;
+ [Throws]
+ boolean checkValidity();
+ [Throws]
+ boolean reportValidity();
+
+ [Throws]
+ readonly attribute NodeList labels;
+
+ [Pref="dom.element.customstateset.enabled", SameObject] readonly attribute CustomStateSet states;
+};
+
+[Pref="dom.element.customstateset.enabled", Exposed=Window]
+interface CustomStateSet {
+ setlike<DOMString>;
+};
+
+partial interface CustomStateSet {
+ // Setlike methods need to be overriden.
+ [Throws]
+ undefined add(DOMString state);
+
+ [Throws]
+ boolean delete(DOMString state);
+
+ [Throws]
+ undefined clear();
+};
+
+partial interface ElementInternals {
+ [ChromeOnly, Throws]
+ readonly attribute HTMLElement? validationAnchor;
+};
+
+ElementInternals includes AccessibilityRole;
+ElementInternals includes AriaAttributes;
+
+dictionary ValidityStateFlags {
+ boolean valueMissing = false;
+ boolean typeMismatch = false;
+ boolean patternMismatch = false;
+ boolean tooLong = false;
+ boolean tooShort = false;
+ boolean rangeUnderflow = false;
+ boolean rangeOverflow = false;
+ boolean stepMismatch = false;
+ boolean badInput = false;
+ boolean customError = false;
+};