summaryrefslogtreecommitdiffstats
path: root/dom/webidl/HTMLLinkElement.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/HTMLLinkElement.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/HTMLLinkElement.webidl')
-rw-r--r--dom/webidl/HTMLLinkElement.webidl69
1 files changed, 69 insertions, 0 deletions
diff --git a/dom/webidl/HTMLLinkElement.webidl b/dom/webidl/HTMLLinkElement.webidl
new file mode 100644
index 0000000000..61b9ec7d5a
--- /dev/null
+++ b/dom/webidl/HTMLLinkElement.webidl
@@ -0,0 +1,69 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://www.whatwg.org/specs/web-apps/current-work/#the-link-element
+ * http://www.whatwg.org/specs/web-apps/current-work/#other-elements,-attributes-and-apis
+ * © Copyright 2004-2011 Apple Computer, Inc., Mozilla Foundation, and
+ * Opera Software ASA. You are granted a license to use, reproduce
+ * and create derivative works of this document.
+ */
+
+// https://html.spec.whatwg.org/multipage/semantics.html#the-link-element
+[Exposed=Window]
+interface HTMLLinkElement : HTMLElement {
+ [HTMLConstructor] constructor();
+
+ [CEReactions, SetterThrows, Pure]
+ attribute boolean disabled;
+ [CEReactions, SetterNeedsSubjectPrincipal=NonSystem, SetterThrows, Pure]
+ attribute DOMString href;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString? crossOrigin;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString rel;
+ [PutForwards=value]
+ readonly attribute DOMTokenList relList;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString media;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString hreflang;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString type;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString referrerPolicy;
+ [PutForwards=value] readonly attribute DOMTokenList sizes;
+ [CEReactions, SetterThrows, Pure]
+ attribute USVString imageSrcset;
+ [CEReactions, SetterThrows, Pure]
+ attribute USVString imageSizes;
+ [Pref="dom.element.blocking.enabled", SameObject, PutForwards=value]
+ readonly attribute DOMTokenList blocking;
+ [Pref="network.fetchpriority.enabled", CEReactions]
+ attribute DOMString fetchPriority;
+};
+HTMLLinkElement includes LinkStyle;
+
+// https://html.spec.whatwg.org/multipage/obsolete.html#other-elements%2C-attributes-and-apis
+partial interface HTMLLinkElement {
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString charset;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString rev;
+ [CEReactions, SetterThrows, Pure]
+ attribute DOMString target;
+};
+
+// https://html.spec.whatwg.org/multipage/semantics.html#the-link-element
+partial interface HTMLLinkElement {
+ [CEReactions, SetterThrows]
+ attribute DOMString integrity;
+};
+
+// https://html.spec.whatwg.org/multipage/links.html#link-type-preload
+partial interface HTMLLinkElement {
+ [SetterThrows, Pure]
+ attribute DOMString as;
+};