summaryrefslogtreecommitdiffstats
path: root/gfx/harfbuzz/src/wasm/sample/c/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /gfx/harfbuzz/src/wasm/sample/c/Makefile
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gfx/harfbuzz/src/wasm/sample/c/Makefile')
-rw-r--r--gfx/harfbuzz/src/wasm/sample/c/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/gfx/harfbuzz/src/wasm/sample/c/Makefile b/gfx/harfbuzz/src/wasm/sample/c/Makefile
new file mode 100644
index 0000000000..4ee073b645
--- /dev/null
+++ b/gfx/harfbuzz/src/wasm/sample/c/Makefile
@@ -0,0 +1,25 @@
+ADD_TABLE = ../../../addTable.py
+
+all: test-fallback.wasm.ttf test-ot.wasm.ttf
+
+%.wasm: %.cc ../../../hb-wasm-api.h
+ clang \
+ --target=wasm32-unknown-wasi \
+ -Wl,--no-entry \
+ -fvisibility=hidden \
+ -Wl,--allow-undefined \
+ -nostdlib \
+ -I ../../.. \
+ $< \
+ -o $@
+
+test-fallback.wasm.ttf: test.ttf shape-fallback.wasm $(ADD_TABLE)
+ python $(ADD_TABLE) $< $@ shape-fallback.wasm
+
+test-ot.wasm.ttf: test.ttf shape-ot.wasm $(ADD_TABLE)
+ python $(ADD_TABLE) $< $@ shape-ot.wasm
+
+clean:
+ $(RM) test-fallback.wasm.ttf test-ot.wasm.ttf shape-fallback.wasm shape-ot.wasm
+
+.PRECIOUS: *.wasm