summaryrefslogtreecommitdiffstats
path: root/gfx/wgpu_bindings/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:37 +0000
commita90a5cba08fdf6c0ceb95101c275108a152a3aed (patch)
tree532507288f3defd7f4dcf1af49698bcb76034855 /gfx/wgpu_bindings/Cargo.toml
parentAdding debian version 126.0.1-1. (diff)
downloadfirefox-a90a5cba08fdf6c0ceb95101c275108a152a3aed.tar.xz
firefox-a90a5cba08fdf6c0ceb95101c275108a152a3aed.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gfx/wgpu_bindings/Cargo.toml')
-rw-r--r--gfx/wgpu_bindings/Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/gfx/wgpu_bindings/Cargo.toml b/gfx/wgpu_bindings/Cargo.toml
index d22253deed..233ea4c92a 100644
--- a/gfx/wgpu_bindings/Cargo.toml
+++ b/gfx/wgpu_bindings/Cargo.toml
@@ -17,7 +17,7 @@ default = []
[dependencies.wgc]
package = "wgpu-core"
git = "https://github.com/gfx-rs/wgpu"
-rev = "0c5bebca514eb06d9387f87666c1c658f3f673b4"
+rev = "d5d683d3c491ec8cd2f5cdb43ac61e526cb7c231"
# TODO: remove the replay feature on the next update containing https://github.com/gfx-rs/wgpu/pull/5182
features = ["serde", "replay", "trace", "strict_asserts", "wgsl", "api_log_info"]
@@ -26,37 +26,37 @@ features = ["serde", "replay", "trace", "strict_asserts", "wgsl", "api_log_info"
[target.'cfg(any(target_os = "macos", target_os = "ios"))'.dependencies.wgc]
package = "wgpu-core"
git = "https://github.com/gfx-rs/wgpu"
-rev = "0c5bebca514eb06d9387f87666c1c658f3f673b4"
+rev = "d5d683d3c491ec8cd2f5cdb43ac61e526cb7c231"
features = ["metal"]
# We want the wgpu-core Direct3D backends on Windows.
[target.'cfg(windows)'.dependencies.wgc]
package = "wgpu-core"
git = "https://github.com/gfx-rs/wgpu"
-rev = "0c5bebca514eb06d9387f87666c1c658f3f673b4"
+rev = "d5d683d3c491ec8cd2f5cdb43ac61e526cb7c231"
features = ["dx12"]
# We want the wgpu-core Vulkan backend on Linux and Windows.
[target.'cfg(any(windows, all(unix, not(any(target_os = "macos", target_os = "ios")))))'.dependencies.wgc]
package = "wgpu-core"
git = "https://github.com/gfx-rs/wgpu"
-rev = "0c5bebca514eb06d9387f87666c1c658f3f673b4"
+rev = "d5d683d3c491ec8cd2f5cdb43ac61e526cb7c231"
features = ["vulkan"]
[dependencies.wgt]
package = "wgpu-types"
git = "https://github.com/gfx-rs/wgpu"
-rev = "0c5bebca514eb06d9387f87666c1c658f3f673b4"
+rev = "d5d683d3c491ec8cd2f5cdb43ac61e526cb7c231"
[dependencies.wgh]
package = "wgpu-hal"
git = "https://github.com/gfx-rs/wgpu"
-rev = "0c5bebca514eb06d9387f87666c1c658f3f673b4"
-features = ["windows_rs"]
+rev = "d5d683d3c491ec8cd2f5cdb43ac61e526cb7c231"
+features = ["windows_rs", "oom_panic", "device_lost_panic", "internal_error_panic"]
[target.'cfg(windows)'.dependencies.d3d12]
git = "https://github.com/gfx-rs/wgpu"
-rev = "0c5bebca514eb06d9387f87666c1c658f3f673b4"
+rev = "d5d683d3c491ec8cd2f5cdb43ac61e526cb7c231"
[target.'cfg(windows)'.dependencies]
winapi = "0.3"