summaryrefslogtreecommitdiffstats
path: root/intl/icu/source/config/gmakever.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /intl/icu/source/config/gmakever.mk
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'intl/icu/source/config/gmakever.mk')
-rw-r--r--intl/icu/source/config/gmakever.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/intl/icu/source/config/gmakever.mk b/intl/icu/source/config/gmakever.mk
new file mode 100644
index 0000000000..6035e6a1a8
--- /dev/null
+++ b/intl/icu/source/config/gmakever.mk
@@ -0,0 +1,31 @@
+## -*-makefile-*-
+# Copyright (C) 2016 and later: Unicode, Inc. and others.
+# License & terms of use: http://www.unicode.org/copyright.html
+#******************************************************************************
+# Copyright (C) 2008-2011, International Business Machines
+# Corporation and others. All Rights Reserved.
+#******************************************************************************
+# Make sure we have the right version of Make.
+
+at_least=3.80
+ifeq ($(MACHTYPE),i370-ibm-mvs)
+at_least=3.79.1
+endif
+ifeq ($(PLATFORM),OS390)
+at_least=3.79.1
+endif
+ifeq ($(MACHTYPE),powerpc-ibm-os400)
+at_least=3.77
+endif
+
+latest_a=$(firstword $(sort $(MAKE_VERSION) $(at_least)))
+
+ifneq ($(at_least),$(latest_a))
+err:
+ @echo "ERROR: $(MAKE_VERSION) - too old, please upgrade to at least $(at_least)"
+ @false
+else
+ok:
+ @echo "$(MAKE_VERSION) (we wanted at least $(at_least))"
+endif
+